Search results | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

Search results

  1. K

    inertia switch

    Update: Again it just crank and no start. Fuel pump relay output working but no input to inertia switch. So I just ran new wire from fuel pump relay output to inertia switch input power and kept original wire connected as it is. Car started and it ran fine. Than I thought to keep new wire...
  2. K

    Anyone actually complete electric fan conversion ????

    You need wiring diagram relays fuses and temperature sensor. In my case I kept low speed fan when AC is on and high speed fan when engine temperature reaches 210F. I installed digital temperature controller (w1209) which is adjustable and 3 relays 4 fuses.
  3. K

    Anyone actually complete electric fan conversion ????

    It was electronic clutch fan, sorry I don’t know what u mean by thevCEI turning. But there is no issue or any error. You will get code only when u scan. No code on cluster. I mainly replaced clutch fan due to loud noise.
  4. K

    Anyone actually complete electric fan conversion ????

    I have installed 2014 Mustang fan RF-394 and now it's been more than 3 years and driven around 50k miles so far so good.
  5. K

    inertia switch

    I just looked around fuse box, the wire which connect from relay to inertia switch it doesn’t look easy job to replace it. Can I just run another wire from relay pin directly to inertia switch?
  6. K

    inertia switch

    I didn’t know it’s only the wire between relay and inertia switch. For now it’s running fine. If engine not starting again I will replace the wire. Thank you very much
  7. K

    inertia switch

    When it doesn’t start I check inertia switch wires and it has no power and all of sudden after few hours power is back.. it happens intermittently. Besides motorcraft fuel pump recently replaced hardly 20k miles on it
  8. K

    inertia switch

    Can someone tell me If engine is running and connection disconnected from inertia switch, engine should stop. Am I right? I'm curious because it never happened. It only happens when I park car and turn off engine, after sometime or few hours I come back and try to start and it keep cranking no...
  9. K

    inertia switch

    I will do that and update here, thank you
  10. K

    inertia switch

    I checked fuel pump relay by tester, one pin which I believe is 30 positive and another pin energise by ignition, ground also working fine 3rd pin I could test by pulling relay slightly but still attached so I could touch the relay pin and confirmed that relay passing power to inertia line. But...
  11. K

    inertia switch

    Car cranks but no start, when i turn ignition on there is no fuel pump prime noise. I checked fuel pump relay and other fuses it all works fine. No power coming to inertia switch thats why no power to fuel pump. I checked fuel pump relay pin which gives signal to inertia switch, it works fine...
  12. K

    Distance between radiator and coolant fan?

    Anyone can tell the distance between radiator and coolant fan. Just wondering if I can install slim design electric fan while keeping clutch fan as it is. I cant measure myself unless I remove my ford Mustang electric fan which I installed in my explorer two years back and reinstall clutch fan.
  13. K

    Engine starts but cranking continues

    I turn key to crank and engine fire up but cranking continues for another 2,3 seconds, could it be camshaft position sensor?
  14. K

    Low fuel pressure (Fixed)

    Your response just made me not to regret for the loss and happy to take motorcraft pump assembly decision :)
  15. K

    Car goes nuetral

    Make sure its right fluid and level is good in transmission, most probably its internal transmission issue.
  16. K

    Low fuel pressure (Fixed)

    Fixed, Since i installed ACDelco pump with wrong hose which is R6/30 and fuel was leaking there was no enough pressure. I was supposed to use R10 fuel submersion hose. Bought motorcraft fuel assembly and reinstalled it.. All good now..
  17. K

    Low fuel pressure (Fixed)

    Yes I changed the fuel filter
  18. K

    Fuel pressure rise after engine shutoff

    Car struggling to start and when Engine runs it seems fine with little vibration at 25 psi of fuel Rail Pressure. If I shutoff the engine, it drops immediately to 8-11 psi and gradually rises to 42 psi. I try to start the engine again FRP drops and engine stalls it won’t start until I wait for...
  19. K

    Low fuel pressure (Fixed)

    From where I should begin to diagnose this problem. Any suggestions?
  20. K

    Low fuel pressure (Fixed)

    Car was struggling to start and when it starts it shakes and sometimes it's normal. I changed fuel pump acdelco and it worked fine for one day. Next day same problem. Checked fuel pressure reading by torque app and it's around 25.0 psi idle, once I shut off engine it drops to 14 psi within...
  21. K

    Battery light on (Fixed)

    Solved! It was broken wire just 25cm before alternator harness. I followed alternator wire which end to harness close to battery. After testing all three harness wires I found out that one has no connection. Once fixed alternator output voltage is back to 14.5v.
  22. K

    Battery light on (Fixed)

    I checked alternator harness which is three pin and only one wire hot, even if car is running or switch on still only one wire hot. Is it suppose to be two wire voltage while switch on?
  23. K

    Battery light on (Fixed)

    It’s three pins harness
  24. K

    Battery light on (Fixed)

    After doing some engine repairs, Battery light came on, Few drops of oil fell down on alternator and I did use brake cleaner spray to clean out the oil. I checked belt, ground, hot wire all look good. Alternator output is 13.6-13.7 which seems bit lower. Is that possible reason for battery...
  25. K

    OBD Code P0106 and P0306 (Fixed)

    Thank God, car is fixed. Also P0106 code disappeared by fixing P0306 only. Thank you everyone for fast responses and helping
Top