Search results | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

Search results

  1. P

    Replace Front Blend Door Actuator in 3rd Gen Ex.

    Still not sure why the Motorcraft part did not work, but spoke with a parts tech from Dorman...... For a "normal" single zone front controller, the Dorman part number is 604-209!! The 604-213 is for the rear air controller. The 604-209 is in, works perfectly, no more "click click...
  2. P

    Replace Front Blend Door Actuator in 3rd Gen Ex.

    #1: Motorcraft YH-1743-1X 1L2Z-19E616-BA ---- Ordered this one online, it has the same number cast into the body of the unit as the factory one: SAE PA6 GF30. Paper tag on other side has: 2L2H-a9E616-AA & 264 11117211. #2: Dorman 604-213... Checking the Dorman web...
  3. P

    Replace Front Blend Door Actuator in 3rd Gen Ex.

    OK, need some help, am I missing a step. Followed this thread, which is fantastic: How to: - Replace Front Blend Door Actuator in 3rd Gen Ex. I've gotten to the point where I have the old actuator out, and put the new one ( new MotorCraft part ), hooked up the wiring, turned the key on...
  4. P

    License plate light/lense

    Question: Anyone have a factory Ford part number ( or good "original style ) for the plastic "lens" for the lights by the rear license plate ?? There's a left and a right, the bulbs & sockets 4tab lock into the lens, and then 2 screws hold in place ( see picture ). Mine are old and...
  5. P

    Transfer case drain plugs

    Going to change transfer case fluid, looking to get new drain and fill plugs. ? Anyone know/have part number for these plugs? Figure if going to do this, don't put the old plugs back in, get new. Thanks!! 2004 Explorer XLT 4.0Flex
  6. P

    Radio static on FM

    Thank you so much for the information!!! Just ordered the item!! :)
  7. P

    Radio static on FM

    Need your thoughts: Just noticed a background tap/static sound from the radio, on FM. Does seem to direct with the engine RPM. I just replaced the ignition coil block ( Motorcraft part ) a few weeks back, but static just started. Noticed small wire hookup to the side of the coil...
  8. P

    2004 Grill emblem?

    Replacing the grill on my 2004 XLT Explorer. Thought would be a good time to put new blue oval Ford emblem in..... but only finding emblem for rear lift gate.. ? Anyone have a good part number for the front grill emblem? Thanks!!
  9. P

    Transmission 1st to 2nd harsh upshifting

    2004 XLT 4x4 4.0 V6, just turned 89K -- Just recently started noticing harsh shift from 1st to 2nd gear... Nothing horrible, just different. Rest of the shifting is fine. Seems to be better when trans is up to temperature/been driving a while. Trans fluid and filter changed within last...
  10. P

    Replace factory radio/single CD unit

    Would like to stay with a factory unit. Put an aftermarket unit in an old S-10 I had, and got a window broken out of the driver door, and found pry-marks on the dash by the radio housing.... so do not want to "bait" that hook... If I can find one, a factory radio is OK with me...
  11. P

    Replace factory radio/single CD unit

    Hi guys! Have a 2004 XLT with the single CD unit - Winter 2014 the CD player started acting weird, and finally died with a CD still in the unit. Bought another unit on line, installed, worked great..... for about four months. Now that unit, when you put a CD in will go quiet for about a...
  12. P

    OBD Lean bank codes

    Has anyone had this problem before: Got a Service Engine light, ran the code, and showed "Left engine bank lean" code. So replaced the left and right O2 sensors. Cleared the code out of the system, and it ran fine..... for a while. About week later, got another code - "Left engine bank...
  13. P

    Blower motor lost bottom two speeds

    Hi guys. I have have a 2004 Explorer XLT 4x4 4.0L - Recently, the bottom two speeds on the blower motor have stopped working, totally. Speeds 3 and 4 and working fine, so I'm not 100% sure it is the motor. ? could be blower motor resistor? What do you think? Thanks!!
  14. P

    ? Rear quarter window dirt rundown?

    Hi guys - Just wondering in any of you have had this problem: Both sides, rear quarter window, I keep getting a "dirt" drip down from each side. This has only started a few years ago. Not sure if this is "normal", just wanted to make sure it is not a problem. 2004 Explorer 4Dr AWD
Top