Search results | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

Search results

  1. S

    Battery and oil gauge

    These type of gauges never tell the whole story. They are either on or they are off. And their normal sitting position is halfway when the vehicles on
  2. S

    oil pressure gauge dropping out, again, 2002 XLT 4.6L 4WD

    Nice write-up. I have the same problem, been doing it for a while I'm going to give this a try. Thanks!
  3. S

    PREDICTED THE BUST, FIXED, ON THE ROAD AGAIN!Check out my transmission pan! With pictures

    In retrospect I've been pretty lucky with the thing. Milage has tapered off due to gas prices. Was doing a lot of "Door-dash" deliveries. Not a problem since I've changed out the sprag. The Transmissions aren't very complicated and pretty reliable with the right upgrades.
  4. S

    PREDICTED THE BUST, FIXED, ON THE ROAD AGAIN!Check out my transmission pan! With pictures

    Tore it down, rebuilt a few times, replacing and upgrading valve body and pump. Trans fluid mod and stick wouldn't budge. Tore down again FINALLY one way plastic sprag was broke apart. Can't tell unless you unseat it and check. It's yellow and at the front of the trans. Everything must come out...
  5. S

    '03 4.6 Coolant in oil

    This guy is right. I'm on my second 4.6 and at 155,000 the first oil adapter failed internally. And now on different engine at 230,000. No oil in the coolant, outer seeping, cracks none of that. Just a sweet weird smell from the tail pipe was my indicator.
  6. S

    PREDICTED THE BUST, FIXED, ON THE ROAD AGAIN!Check out my transmission pan! With pictures

    My question is if this is normal wear and tear on a used transmission I threw in a year and a half ago. While doing so I cleaned out the pan so this is all new material. Keep in mind I've been in four-wheel drive a few times been through one winter and have put about forty thousand miles on it...
Top