Search results | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

Search results

  1. M

    Shift linkage won't stay connected! HELP!

    All- Been a while since my last post - been busy with a newborn...and I do mean busy. Anyway, driving today, and went to back out of a parking spot, and when I shifted into drive nothing happened - and I was still in reverse. Shift lever moves nearly free in each direction with no change...
  2. M

    GreenFoot Global

    I agree that MLM usually spells scam...and in the case of these things I'm skeptical. Thanks for the input guys...
  3. M

    GreenFoot Global

    Well now I have my MLM obsessed grandparents pushing this product on me to become a distributor...has anyone used it, or know anyone who has? I agree with the above that there are other additives significantly cheaper that more than likely do the exact same thing. A quick google search about...
  4. M

    GreenFoot Global

    I am staunchly anti-Multi level marketing as IMO its just another name for a pyramid scheme. However, this one seems that it may be legit and a guy I work with is selling this stuff. Any thoughts? It's another of the too good to be true products...I think its BS...
  5. M

    Gas Mileage

    Man, hell yes I kept track! Pre-tuneup - I was at most getting around 10-13 mpg and running so rich my exhaust may have been flammable. I used Bosch O2 sensors from Autozone. One of the O2 sensors looked clogged, I don't know how it wasn't giving me a CEL... Another thing I did was a few...
  6. M

    Gas Mileage

    After an extensive tuneup, full exhaust replacement, and O2 sensor replacements, I'm getting close to 20mpg but I do 99% highway driving. My office is right off of the highway so I don't take into account any non highway driving.
  7. M

    My 93 is misfiring.

    Just had the same problem! Check your plugs and wires first...I had 3 cracked plugs...replaced and fixed. Also, vacuum would be a good place to start....
  8. M

    Suddenly missing

    Well, you guys all know what spark plugs look like, so nevermind on the pics. On a plus side, brand new set of plugs fixed it completely. What a relief....
  9. M

    Suddenly missing

    Lucky me :) A few of the plugs had cracked insulators...pics to follow. Why would this have happened? The plugs are barely a year old? No overheating issues either....
  10. M

    Suddenly missing

    Good god, that's ridiculous
  11. M

    Suddenly missing

    Will do the balance test BUT Just figured something out....never checked my FPR. Pulled the vac line, looks dry. Got out a pen light, and down inside the line its soaking wet and the nipple on the FPR is wet....with gas. Think I just found my issue...agreed?
  12. M

    Suddenly missing

    OH good, Now it continues even when its warmed up....any thoughts based on a new symptom?
  13. M

    Suddenly missing

    Assuming wires are routed correctly, How would I have cracked a plug? This would be a new issue for me...I've never had that happen. Based on the symptoms though, is it fair to say its an ignition problem more than likely?
  14. M

    Suddenly missing

    OK, I am at a loss here. Replaced my entire exhaust system, including removing the manifolds and adding a gasket to each side. No leaks, I finally have a quiet car :) However, Early last week I noticed a really bad miss when the motor is cold that only slightly improves once...
  15. M

    Anyone alive in here?

    Old Post I know - but when are we all getting together :D
  16. M

    Roll call

    Jeremy, Monroe (north of Cincy)
  17. M

    '04 4WD "roaring" sound

    I did have an issue a few years ago where I didn't torque the castle nut back down and the bearing was just loose - but it needed replaced by the time I looked into it. Another issue may be packing - how well did you pack the bearings?
  18. M

    '04 4WD "roaring" sound

    Wheel bearing would be a good place to start as well as lugs. I had new tires and an alignment done and drove off the lot to the same thing on my 93 and was furious. They forgot to tighten my lugs all of the way....scary.com
  19. M

    Which bolts do I need

    As do I - UPS guy dropped off exhaust parts while I was in the garage and was amazed I knew how to do exhaust. I just kinda stared at him dumbfounded - I never really realized that the skills we all have with these (or any) trucks/cars is a dying thing Kudos to all of us who do the work...
  20. M

    HELP ASAP with vac lines

    Dumb question, but isn't there a vacuum diagram in your chilton/haynes? Or even somewhere under the hood? I have a huge file of them somewhere, I should be able to upload one when I find it. Good luck in the meantime
  21. M

    Which bolts do I need

    Nexis - like that Idea :D But I'm too cheap to pay someone else 40 bucks - and the closest shop is Meineke and that won't fly for them...at least areound here.
  22. M

    Which bolts do I need

    Well I picked up 10.8 flange heads at Ace, so once all of my parts show up I'll begin the install. In the mean time, I have been soaking those bolts with PB Blaster, and I plan to continue to. I have a pencil torch I may use to heat them up as well. Thanks for the input - its going to be rough...
  23. M

    Which bolts do I need

    So, I will be posting pics of this job. You would not believe the trouble I've run into. I've not seen so much rust in my life....have replacement parts by the weekend pics to follow. Thanks for the input all of you!
  24. M

    Which bolts do I need

    Will I need nuts or is it a fitting that the bolts go into?
  25. M

    bad gas milage =/

    I have the same issue with MPG but mine is due to an exhaust leak. Excess air is flowing into the exhaust and messing up my O2 readings and the ECU is compensating by running chokingly rich. To be fixed this weekend tho...
Top