Search results | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

Search results

  1. S

    Cooling system pressure tester

    I've checked a couple of AutoZones in the Detroit area. The pressure testers that they have don't come with an adapter to fit on 2000 Explorer. The kits come with an adapter to check the radiator cap, but not the adapter to connect to the radiator. Anyone know what kind of adapter I might need?
  2. S

    Help me out! Charging System Not Working!

    Probably hard to figure out with out a meter. Its really easy to tell if the charging system is working with a meter: with the car off measure the voltage at the battery it should be around 13 volts. Then start the car, the voltage at the battery should now be 14-15 volts. According to my...
  3. S

    Belt Tensioner

    It was the belt tensioner, the new one does not go past about 7:30.
  4. S

    Belt Tensioner

    I replaced the brushes in my 95 amp alternator yesterday. Now the belt tensioner has rotated past where it applies tension. Looking from the front it has continued clockwise past 9:00. Does the serpentine belt stretch, or is there something wrong with tensioner? BTW: No one was selling...
  5. S

    Introductory Hello

    I wonder if you son got his coolant leak fixed yet.
  6. S

    2000 4.0 OHV Saga

    Coolant leak was coming from the upper radiator hose where it connects to the thermostat housing. I was never able to find a pressure tester to try, but that was my best guess earlier. Exhaust leak is fixed. I didn't know that Bosch plugs sucked so bad. I put them in this spring. 3 of...
  7. S

    Spark Plugs

    Don't use Bosch. I replaced my original plugs with at 105K, just put Motorcraft in at 108K.
  8. S

    2000 4.0 OHV Saga

    Well, I dropped off to an unknown local mechanic this morning. I'll post back what he finds to assist others.
  9. S

    Unknown Coolant leak.

    Is the O ring that goes around the thermostat the only gasket for that housing? When I bought my gasket kits it also came with a fiber gasket, but I didn't put it on, because it wasn't there when I removed the thermostat.
  10. S

    Unknown Coolant leak.

    My coolant pools in the front on the passenger side also. I haven't figured out were its coming from yet. I check two AutoZones for pressure testers, but both of them didn't have the correct adapter to connect to the radiator. Strangly it had an adapter to check the cap, but not a reducer to...
  11. S

    2000 4.0 OHV Saga

    I got a cooling system pressure tester from AutoZone, but I haven't had a chance to try it yet. My oil level is definitely rising. Does it make sense for coolant to get into the oil, but not the other way around? Is there anyway for the coolant to get into the oil other then at the head...
  12. S

    2000 4.0 OHV Saga

    Shamaal - Definitely coolant. I picked up a pressure tester from AutoZone, but I haven't tried it yet. I did put a some HighTemp RTV copper silicone between the manifold and exhaust, but still have the leak some where. Its hard to feel for the leak with all the air from the fan. :banghead:
  13. S

    How to: IAC valve cleaning thread (w/pics)

    Nice pictures. I just figured out where that "eight shaped" rubber gasket was supposed to go that came with my upper gasket kit.
  14. S

    2000 4.0 OHV Saga

    Still have coolant on top of the intake manifold. Its puddled around the fuel injectors on cylinders 2 & 3 (near the front of the car). The heater control valve looks bone dry, so does everything else. Bummer.
  15. S

    2000 4.0 OHV Saga

    Thanks, I'll try the high-temp RTV. Those were my hardest bolts to get off. I bought a lot of new tools and rented an electric impact wrench.
  16. S

    2000 4.0 OHV Saga

    Getting better. The Check Engine light stays off!!! :) I took the upper intake off again, I noticed that one of the studs holding the fuel rail down was up about a quarter of an inch. When I took the upper intake nuts off to get the vacuum line out, some of the studs must have loosened up...
  17. S

    Driver's Side Door Lock is Broken

    WOW, that's great. It took me quite a while to figure out that the clip even came apart.
  18. S

    Driver's Side Door Lock is Broken

    My driver side door would only unlock by pulling the door handle from the inside. After removing the interior panel, I couldn't see anything wrong with the linkage. After playing around with it for a few weeks I noticed that if you held up one of the linkages a little bit when it was locked...
  19. S

    keyless entry how dose it work

    On my 2000 the light goes on as soon as I start pressing buttons. You still might be entering the wrong code.
  20. S

    Considering '00 XLT, what to look out for?

    If its the VIN X engine (OHV 4.0) watch out for cracked heads and leaky gaskets. Make sure it idles really smooth, that was the first sign of many troubles on my 2000 XLT.
  21. S

    2000 4.0 OHV Saga

    This is starting to get frustrating - I took the exhaust manifold off again, put new studs, nuts and a new gasket in. Maybe its not an exhast leak. Still makes the same noise. Kind of a clicking, much louder under load when accelerating. Maybe something with the valves/rockers?? I...
  22. S

    2000 4.0 OHV Saga

    At 72K my engine started idling rough and the engine light came on. The dealer said they found both cylider heads cracked and after more than $3,000 I got my truck back. Well at 101,000 engine light is back on and idling rough again. P0305 cylinder 5 misfire, according to Auto-Zone. I...
  23. S

    2000 4.0 OHV Saga

    At 72K my engine started idling rough and the engine light came on. The dealer said they found both cylider heads cracked and after more than $3,000 I got my truck back. Well at 101,000 engine light is back on and idling rough again. P0305 cylinder 5 misfire, according to Auto-Zone. I...
  24. S

    Left turn signal smoke?

    That's great! A bunch of Explorer's going down the road with the steering coumn in pieces. My '00 Explorer started doing the same thing about 6 months ago. I've been drivng with the top of the steering column off for the last two months.
  25. S

    Explorer shakes at 60mph

    Suprise, suprise. The vibration stopped completely. The mechanic said it might work itself out. I gave the steering a couple or hard cranks when I was standing still and the vibration was gone!
Top