Search results | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

Search results

  1. V

    brake pads aren't fitting into slots

    The person who installed them before had to grind the pieces on the end that go in the slots. I think that rust that had formed into a solid is what made it not fit and thus have to be grinded. I made sure not to grind them this time....tight fit still though. guys at advance...
  2. V

    brake pads aren't fitting into slots

    I used one with a retaining clip on both sides.... I was wondering at first if I did put them on the wrong side . ALl of them were marked the same way with L and R But I did get them in just now, thank the Lord I got the flash light and shined it on both the slots and the bottom...
  3. V

    brake pads aren't fitting into slots

    Had a problem with my old brake pads that I had a buddy installed. he had to grind the ends down a bit to get them to fit in the slots. Long story , short the pads got all messed up and made some crazy sounds. Check my old posts for pictures. anyhow I went to advance to get a set of weaver...
  4. V

    brake problems...explorer is down

    yea man it for sure is like a windex spray. I was under there and it was going all over the place. between that and the salt I am sure its going to be super rusty back there for a while. I sprayed the water hose under the entire truck a little bit ago, and it was dripping...
  5. V

    Brakes Grinding

    hey fellas , I posted some pictures up in my original thread about this problem. I was searching for similar problems and found these posts. was a rust spot build up on the inner area of the rotor, whatever it is , its bad. I put high temp grease on the pistons and anything else...
  6. V

    brake problems...explorer is down

    well I got the brake line fixed.. $67 . Went to buy a caliper today at advance auto and they didn't have the one in stock that I wanted so I just told them Id order it from the website. but I went home and wanted to check for any rubbings or anything else to know for sure I need a new...
  7. V

    Brakes Grinding

    Id love to buy both sides and everything else to be done with it for a while anyhow , but I got tuition to pay and books to buy can't really afford all the stuff. Just need to get rid of that dang noise. edit: just a note I am not a big cheapo just this thing is starting to take all...
  8. V

    Brakes Grinding

    The brake paids were not fitting in right on some of them , so my buddy grinded em to fit. He also put the spacers in , at about a month into it we pulled the calipers again , and the spacers were ate up ...we thought they were causing the problem, as they were rubbing against the rotor or...
  9. V

    Brakes Grinding

    sounds like I am having the same noise , but comes at differnet times then yours. WHen I stop after the brakes are heated up I get this loud rubbing noise coming from the passenger front. This happend after I put new brake pads on all around (weaver gold series) go figure, no brake noise...
  10. V

    getting the brake line nut loose at the rear drivers side

    well I ended up taking it to the auto shop a couple blocks over from here. hated to leave it there, but it needed fixed ASAP. Just didn't have the tools to do the flanges , connections I checked the line when I got home, the new line only runs from the back to about the middle of the...
  11. V

    getting the brake line nut loose at the rear drivers side

    I did not get the clip out yet , but I see it there, just a little rusty and needs some coaxing to get out. I got a friend who works at a nearby mechanic shop said I could just cut the line and then run a new line , just as long as its not touching any metal of the frame I should be alrigth...
  12. V

    getting the brake line nut loose at the rear drivers side

    I posted on here about another question about my brakes making noise...then one of the lines ruptured and posted in there to get some help on doing that...no takers. So I am trying to get more exposure to this by making its own thread. The brake line that is ruptured has a pin hole leak...
  13. V

    brake problems...explorer is down

    found the leak this evening. Its the main brake line that goes back to the driver rear. Right where the connection is for it to go the rubber brake hoses. Tire looked wet and my shock looked wet so I put in some brake fluid and had a buddy hit the brake and sure enough , pin hole leak...
  14. V

    brake problems...explorer is down

    Yea I didn't like when he had to grind the pad to get it to work. Advance auto parts is where I got them from. Just gave em the specs of my explorer and they went and got them. It wouldn't be the first time they gave me the wrong part though, they gave me a thermostat from a SOHC engine...
  15. V

    brake problems...explorer is down

    My 98 explorer sport was needing new brakes so I got them all replaced a buddy of mine who is a mechanic did them for me while I was there. We went and bought advanced auto parts brakes , It was either the silver or the gold series. When fitting them in he had to grind them a little bit to...
  16. V

    second brake resivor?

    yea I have a standard...why is it so hidden and hard to fill up.
  17. V

    second brake resivor?

    I have had this truck for 4 years, and the other day while chaning out the thermostat and waiting for it to warm up, I was lookin around the engine and found this second brake resivor tucked in behind the master fuse box/relay box. It says only put in Dot 3 brake fluid etc etc, the hose...
  18. V

    Cant Find Coolant Leak

    can you do an aerial photo so I can really pin point what is circled? But from where it's at now It looks like you got your heater hoses circled.
  19. V

    Autotap Scanner on 4.0 OHV

    I don't know the name of the scanner, but we hooked mine up the other day to check the coolant temp and the scanner showed all my O2 sensors at -100% and 0 voltage. But no error codes relating to the O2's. Only error code was the p1405 and I replaced the hose for that , as it was...
  20. V

    p1104

    Thanks for the information....I hope it's not a bad maf, I figure one of those would be pretty pricey. anyone know where a diagram for the maf is?
  21. V

    Help with an error code

    I posted this in 2005 on the under the hood section with no help ..yes I know a long time ago. 98 exploer 4wd sport: Today I had my buddy run a diagnostic check on my explorer due to the check engine light coming on, flashed code p1104 Which was about an upstream valve or hose either...
  22. V

    p1104

    I just googled the error code and came up with this P1104 MAF Ground Malfunction that is differnt from the descrption in the book he read, but that is for sure the error code my explorer gave. Could this be what is causing my bad gas mileage? any help on how to fix this...
  23. V

    p1104

    bump this old thread to see if anyone knows anymore about it.....check engine light still on from this code.
  24. V

    Radio / Clock display problem 1998 and up Explorers ( blank / fade / blanks / fades )

    thanks for that post man, I will re do mine when I get a chance, hopefully this weekend or the next. I was in Electronics Engineering Technology for 1.5 years and worked a summer in the field (thats when I realized I dind't want to do that haha) so I should be able to take care of this.
  25. V

    Radio / Clock display problem 1998 and up Explorers ( blank / fade / blanks / fades )

    has anyone just tried replacing the resistors? I imagine replacing every part on the board would still be cheaper then the new board for 75+ Mine came on today again for about 2 minutes (it was about 7* out) I went to set the clock and she went blank again as I was about to set the minutes
Top