Search results | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Search results

  1. K

    Ford Ranger 4.0 high RPMS

    I have a 2000 Ford Ranger 4.0 with 96k on it. I've had it for a little over a year and it's been one problem after another. Recently I was driving on the interstate and it started bucking at 60 mph. After I accelerated to 70 it stopped. It only did this for about 1/4 mile. I haven't been...
  2. K

    2 Transmission problems

    I believe I have found the cure. I found some trans additive made by Lubeguard that is supposed to turn whatever type of tranny fluid that is in the tranny into Mercon V. I admit I had little to no faith in the stuff, however I had no other ideas. I paid 12 dollars for a bottle and poured it...
  3. K

    2 Transmission problems

    I have this same problem and noone seems to be able to shed any light on the subject. I have had all the bands and clutches replaced along with the valve body and all the solenoids. My next guess was the intermediate servo, but I'm not sure at all.
  4. K

    5r55e Shifting problem

    Is it possible that the intermediate servo is malfunctioning? This is really the only thing I can come up with that hasn't been changed out.
  5. K

    Parasitic draw on battery

    It is possible that you may have been given a bad battery from where ever you bought it.
  6. K

    cranks but wont start

    It could be the crank sensor. You could have a bad coil, ignition control module, etc. Has the engine thrown any trouble codes?
  7. K

    cranks but wont start

    No spark means that the fuel that is being pumped into the engine is not being burned. Once the cylinder is full it will hydrolock. Fix the spark issue and the lock problem will go away.
  8. K

    5r55e Shifting problem

    I have a 2000 Ford Ranger XLT 4x4 4.0 with the 5r55e transmission. I recently had the transmission rebuilt and the valve body replaced along with all solenoids. However, when the truck heats up, it intermittently will not shift into third gear unless I let off the accelerator. It shifts...
  9. K

    92 explorer engine siezed after synthetic change

    It's not synthetic oil by itself, but when you switch from conventional to synthetic. It could still be a wives tale for all I know. I've never used synthetic so I don't know much about it.
  10. K

    92 explorer engine siezed after synthetic change

    Seems like I remember reading somewhere that if the engine was not originally ran with synthetic oil, that switching to synthetic oil was a bad plan. You could have hydro lock but that doesn't explain the banging. If you pull out the spark plugs and gasoline shoots out of one or more of the...
  11. K

    Superior shift kit installation problems

    I went ahead and took it to a transmission mechanic. I didn't want to do any permanent damage, but I will update this post with the information that I get from the mechanic.
  12. K

    locks dont work right anyone help?

    Ford put a small piece of carbon inside the door actuator motors so that the carbon would burn out before the motor. Funny thing is the plastic actuator housing is "not serviceable"...at least not without a little ingenuity. The process basically involves popping the plastic actuator housing...
  13. K

    Superior shift kit installation problems

    I recently completed the Superior shift correction kit installation. I have a 2000 Ford Ranger XLT 4x4 4.0 engine with the 5r55e tranny. After completing the superior kit installation, I now have a very weak reverse. It only backs up on flat ground. Also all shifts are very harsh except for...
  14. K

    A4LD Governor Replacement

    I have this problem also (won't shift under acceleration). I notice some transmission fluid on the bottom of the tranny pan. My truck is a 2000 model 4X4 with 83k on it. The dealer said that they just had the transmission rebuilt. I took the truck back to the dealer and they kept it a week...
Back
Top