Search results | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Search results

  1. L

    Coolant leak

    Thanks for that Number4, as soon as I get it back from the shop I will see about doing that to mine.
  2. L

    Coolant leak

    I will have to see if I do something about that cap, I will look around and see if I can find your thread on it. Thanks for the help Number4.
  3. L

    Coolant leak

    Hi Number4, It was and it did have that yes, the cap is still in place. He ran a scope thing with me there and the freeze plug is definitely out with a gap between it and the engine. Any idea how hard that is to replace? I know he is looking into it but I am curious for my own information also...
  4. L

    Coolant leak

    I ended up taking it to a mechanic friend who found that the freeze/expansion plug at the rear of the engine popped. He's going to see how much of a pain it's going to be to replace it. Thanks for the help shane.
  5. L

    Coolant leak

    Hi, I have a 2005 Ford Explorer 4.6l that has a coolant leak that looks like it's coming from above the starter on the passenger side. Up top looks dry and I can't see where it might be coming from. I have no more coolant in the valley of the engine after replacing my intake manifold because it...
  6. L

    Strange Wire

    Found a couple of cracks in both of those hoses by bending them after taking them off, also found the purge valve was stuck. It had vacuum even unplugged and from what I've read it should be closed with no power so I replaced it also. Now it runs and idles but is still rough and still seems like...
  7. L

    Strange Wire

    I pulled loose the plug for MAF sensor and it does run and drive it's just really rough and the engine wants to surge tested wires for MAF for ohms to see if there was a break in them and didn't find anything. So...had the MAF loose and thought I might check again for vacuum leaks with started...
  8. L

    Strange Wire

    Hey Joe, yes I do. It's how I originally tested the voltage coming from the maf sensor and then I manually tested with a volt meter. What would I be looking for exactly? Thanks again.
  9. L

    Strange Wire

    Thanks for the insights on the breather box Drew, I appreciate it. I will do some more testing on the MAF once my breather box has fully cured. I took your suggestion Drew and found some heavy plastic with some jb weld plastic weld and sealed that hole. Joe, out of curiosity is it possible the...
  10. L

    Strange Wire

    Hey Joe, I know the old MAF I had was faulty. I replaced it, what's the chance even with it reading correct voltage that the new one is faulty also?
  11. L

    Strange Wire

    Thanks for the information Drewmcg. Just some background on my 2005 Explorer with the v8 and what prompted all of this. Originally I started with overheating at idle which went from being at idle to all of the time so I checked the normal things, the hoses for cracks and the radiator for hot...
  12. L

    Strange Wire

    Sorry, I was going to do this but have been busy. Attaching pictures to this post, I've removed the air filter box from the vehicle. It appears there should be some plugs that go in these and that one has been busted out before I purchased this vehicle. Would this cause my Explorer not to idle...
  13. L

    Strange Wire

    On a different note, should my air filter tray have a whole that you can see through to the ground? It's situated near the middle on the side closest to the coolant reservoir and looks like something should be in it. Thanks again.
  14. L

    Strange Wire

    I went through 4 explorers that were all 2004-2006 and someone had taken all of the wiring harnesses out including that piece....just my luck. Then it crossed my mind, I wonder if an expedition around same year would have it....sure enough there it was and easier to take loose than it was on my...
  15. L

    Strange Wire

    Thanks Joe, will do if I can find the thing. I may have to resort to going to a junkyard for it. Thanks again
  16. L

    Strange Wire

    Am I correct in thinking it's just for reducing electronic noise to the radio? If so, can I just tape it off so there's no bare wire hanging out? Thanks
  17. L

    Strange Wire

    Thank you very much, Joe in NY. You are a lifesaver, I looked all over Alldata and elsewhere without finding what that thing was. Just out of curiosity, if that isolator is missing what kind of issues might I have? Thanks again.
  18. L

    Strange Wire

    Hi everyone and thanks for looking, I found this odd wire that goes to a single blade connector that I have absolutely no idea what it is for. It appears the connector itself is snapped off of something. I have a 2005 Explorer with the 4.6l engine. This wire is taped in with the coil pack wires...
  19. L

    2005 Ford Explorer Washer Fluid Pump

    Hi, I just got around to putting in a new reservoir as mine was missing completely and the connector for the pump is just bare wires. I tried using a multi-meter to determine if I was getting power to the wires or not and it appears that I'm not. I also tried jumping them to the wires coming...
  20. L

    How many miles will an explorer go for?

    Sitting at 240k miles on my 05 Explorer, only thing was wheel bearings due to neglect from previous owners. Ended up having to replace all 4.
  21. L

    Loaded Rear Knuckles

    I finally got it to go on, I had to do exactly how you said kydirtscooter. I got the Moog one that is listed here and it went in great, like I said it seems to be of better quality than the original one that was on it. If we could have gotten the snap ring out I would have just put in new...
  22. L

    Loaded Rear Knuckles

    Long time lurker, first time poster. I just got done installing one of these on my 2005 explorer eb and it seems just like the old one but better. Heavier duty it seems to me, only issue I am having is getting the brake caliper to go into place correctly so I can screw in the guide holes. domct...
Back
Top