Search results | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Search results

  1. N

    2017 doesn’t really get much heat

    I have a ‘17 Explorer that doesn’t produce much heat anymore. Fan speed seems to have not very much change between the lower ones until 6 and 7. So thinking a resistor? Blend doors are cycling through defrost, forward and feet area. On the rear you can definitely notice all the changes in...
  2. N

    No power when pedal pressed, and then would take off on it’s own..

    Well. Looks like I finally found the problem. Decided to try the gear selector and ordered a one off of ebay. Ran good with no problems. Never thought that would be the problem.
  3. N

    No power when pedal pressed, and then would take off on it’s own..

    For reference. Past week has been cold, clear and windy mostly. -35 to -40c and windchill -40 to -55c. Edit-Think thats why my explorer, on it’s 7th winter and first -50 day. It just said “f*ck this sh*t”. And started acting up like this. 🤣
  4. N

    No power when pedal pressed, and then would take off on it’s own..

    Today is a warm day, -21c(-6f) and windchill -30(-22f), everyone out busy fishing, playing, I am busy wrenching outside on my race snowmobile. Changing gearing. Our local Cross country/drags races and hillcross in April.
  5. N

    No power when pedal pressed, and then would take off on it’s own..

    Thanks. Am hoping it just doesn’t like the cold anymore. Will see in a month or so when it warms up above -15c or so. I tried finding the MAF sensor like someone stated above. But this vehicle doesn’t have one after an extensive search. Oh well. Called stealership and found a 21 Lariat with...
  6. N

    No power when pedal pressed, and then would take off on it’s own..

    Not the fuses. It started acting up again last week. Then got bad again couple days ago. The guy that reflashed it said can’t keep going to try reflash. As he has the whole municipal’s fleet of heavy equipment and all there trucks between 2 of them. Just doesn’t have the time. May try MAF sensor...
  7. N

    No power when pedal pressed, and then would take off on it’s own..

    Well, never thought it would have been the fuses. Switched around the 3 different micro blade power control module fuses, and pulled out and reinserted the 70a square one. None pf them looked broken, so switched them around with matching amp other fuses. And it is working normal again. Reason...
  8. N

    No power when pedal pressed, and then would take off on it’s own..

    Well, he didn’t have the time to try soldering the wires on. He tried bending the prongs a bit to make the connector tighter. Trying to prevent the connector from loosing contact in the extreme temps-40*c without windchill, -50-60 on some days with windchill. And yes, the windchill temps come...
  9. N

    No power when pedal pressed, and then would take off on it’s own..

    Just brought it back to the same guy to that has the fordscan. And half way there it went back to normal, so no reprogramming required. Was coasting, switching from drive to select shift to give it a lil boast when it shifts. Small community, so not very much traffic. He said there is another...
  10. N

    No power when pedal pressed, and then would take off on it’s own..

    Well, back to square one. Same symptoms. So will need to reflash power train control module again. Question is, could the module be bad and require a new one? For it to require a flash and only last a day?
  11. N

    No power when pedal pressed, and then would take off on it’s own..

    Well. Was finally able to get it on fordscan( luckily the towns municipal mechanic had one). He had to reprogram the power train control module. That problem wasn’t showing on my obd2 scanner. Atleast I have a new throttle body and accelerator pedal. 🤣 All working good now.
  12. N

    No power when pedal pressed, and then would take off on it’s own..

    Well, I got the correct throttle body. But still no change. I don’t know what else to try. Will try get a place to get in the shop to thaw out for a couple days this week. No time to work on it right now due to work. Still no response when in reverse or drive. But when parked rpms go up. So am...
  13. N

    No power when pedal pressed, and then would take off on it’s own..

    Well, I did get the throttle body. Unfortunately it was for the platinum/sport models. Although it did state it would fit my XLT. So sending it back for refund. Did get the proper one ordered that day. So a waiting game again. Merry Christmas and happy holidays all!! Will update once I get the...
  14. 72BFD391-083A-4673-96AB-AB30DBD0172A.jpeg

    72BFD391-083A-4673-96AB-AB30DBD0172A.jpeg

    Northern Lights
  15. 07AB53AA-AC13-43F6-A217-4DF041B3A73B.jpeg

    07AB53AA-AC13-43F6-A217-4DF041B3A73B.jpeg

    Northern Lights
  16. 00C3958E-8823-457B-BB95-E735D63201D8.jpeg

    00C3958E-8823-457B-BB95-E735D63201D8.jpeg

    Northern Lights
  17. 4E1B0C74-2AE4-44C5-AFE6-FFF136EC1844.jpeg

    4E1B0C74-2AE4-44C5-AFE6-FFF136EC1844.jpeg

    Northern Lights
  18. 8873E6BF-B1E1-4349-968D-8C1C4302C206.jpeg

    8873E6BF-B1E1-4349-968D-8C1C4302C206.jpeg

    Northern Lights
  19. ABF7CC8F-AC10-4A9B-886E-0E84A9E04E57.jpeg

    ABF7CC8F-AC10-4A9B-886E-0E84A9E04E57.jpeg

    Northern Lights
  20. 48941773-3CC7-4DA4-86C7-9043DA504B43.jpeg

    48941773-3CC7-4DA4-86C7-9043DA504B43.jpeg

    Arctic travels
  21. BD943633-DACE-491E-B430-B8661961D891.jpeg

    BD943633-DACE-491E-B430-B8661961D891.jpeg

    Arctic travels
  22. EEFB6C8F-6C75-4579-B963-747DAF672A90.jpeg

    EEFB6C8F-6C75-4579-B963-747DAF672A90.jpeg

    Explorer and Northern Lights
  23. 881A4190-2033-4C67-9E79-46D5CB5E7C92.jpeg

    881A4190-2033-4C67-9E79-46D5CB5E7C92.jpeg

    Northern Lights
  24. AEA5E4D0-977D-4F6C-8E90-A7DC3DBFFFA9.jpeg

    AEA5E4D0-977D-4F6C-8E90-A7DC3DBFFFA9.jpeg

    Explorer and Northern Lights
  25. C9B6AFE9-4B94-469F-8614-141AA9D8821E.jpeg

    C9B6AFE9-4B94-469F-8614-141AA9D8821E.jpeg

    Northern Lights
Back
Top