Search results | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Search results

  1. C

    Radiator removal/Installation

    Currently reading the Haynes manual on this job, which suggests the removal of the fan in the process. I've seen a few videos skip this step. So my question is, can I still follow the manual while also skipping this step? Or is there something else I have to do? Thanks!
  2. C

    Engine/Transmission swap

    Thanks for the advice, funny that you mention Dana because I do work there lol. And I'm 25 and just new to working on cars in general.
  3. C

    Engine/Transmission swap

    I've looked up several topics on the forum and have come short. I was just wanting to know where is the best place to start looking/reading up on how to do engine/transmission swaps for a first timer, and how difficult it is for someone who hasn't done it before. I'd say I'm still a beginner...
  4. C

    Random Cylinder Misfire

    Sweet, thanks man! I didn't want to take a chance on ignition coils, but I decided to order another set of 8 anyways. I'm a little over 140,000, and I just changed the spark plugs. The spark plugs are Champion brand coppers, which might be part of the problem. I also had a specific cylinder...
  5. C

    Random Cylinder Misfire

    Got a CEL code for a P0300. The explorer has had some random hesitations/stumbles the last month so I knew something was going to come up. CEL came on as I started to accelerate pretty hard. It even blinked for a few seconds before turning solid. The spark plugs are recent, only 3 months old...
  6. C

    violent shaking/vibration at highway speeds

    Just started happening tonight for me on the way to work. From 0-40 it's barely noticeable. Around 50 I get this weird feeling in the steering wheel. Hard to explain but it feels very "airy" or free from any weight as if there's nothing connected to it. After 55-70 the shaking is more pronounced...
  7. C

    beeping noise after starting car?

    Yep, it was the parking sensors. Had a little ice on them, it wasn't much so I scrapped the sensors off with my finger nail and it's back to normal.
  8. C

    beeping noise after starting car?

    Yes, I have those, but this bleep makes a different kind of noise from the backup sensors. Or maybe it is that and the noise sounds "distorted" because it's very cold out, and possibly ice/snow on the sensors. I'll check them out before I go to work.
  9. C

    beeping noise after starting car?

    I've done a quick search of the forum and found nothing. It's only 1 beep (or more like a "bleep" if that makes any sense). It doesn't happen right after I start the car but it happens when I put the car into reverse. Has anyone had this happen or at least heard of this? I'm getting paranoid...
  10. C

    attempted to change brakes for the first time today

    I got my front brakes and rotors from autozone. They're both duralast brands and the brakes are ceramic. The current set of brakes that are in here are some duralast metalic pads with the horrendous brake dust. It's pretty cold here in Indy so I'm waiting until the last "warm" day which is...
  11. C

    attempted to change brakes for the first time today

    And I ran into a couple problems. 1st problem: My wheels were way overtorqued. They were at least 150 ft/lbs. The last time they were messed with was when I got a rotation and inspection done 6 months ago. Will this harm my wheel/lugs/studs at all? 2nd problem: My brake pads didn't fit...
  12. C

    One wheel is dirtier/blacker than the rest

    Not sure what's causing this but one wheel on the front has some black dirt or whatever. The rest don't. What could be causing this? I took it to the car wash 4 days ago and that one rim/wheel is back to being covered in dirt again. Edit: it's actually both my front wheels. The left side is...
  13. C

    Blown Head gasket

    Just curious to see what I would be paying for the worse case scenario of a blown head gasket. Last summer my car overheated, since then I've pretty much driven it like this. I dont have the atypical symptoms like oil in the coolant, or coolant in the oil. I do have a little engine/(rod?)...
  14. C

    Going through gas at an alarming rate

    Sorry about that. To give a better figure, I lose 5 gallons for every 30-50 miles driven. After Friday I stopped filling up the tank and only put 5 gallons in every fill up to get a better picture at how much gas I'm using. I reset the ECM multiple times after those repairs/cleanings. The...
  15. C

    Going through gas at an alarming rate

    Within the last week, I've been going through gas like crazy. Fuel economy was okay after fixing my air intake problem that I was having in my last thread. Recently I changed the air filter, spark plugs, cleaned my throttle body and MAF sensor. Added seafoam to my gas tank 3 weeks ago. This...
  16. C

    Explorer dies at a complete stop

    I took the air intake apart and adjusted the last known ignition coils I worked on, also did a reset on my computer. The truck idles at around 700-800 consistently now. The shaking/vibration is minimal, although now I hear this constant "clicking" under the car. The only issue I have now is...
  17. C

    2004 Explorer V8 accelerator pedal problem

    Yes, I believe that allows the computer to relearn the new idle.
  18. C

    Explorer dies at a complete stop

    Another thing I'll add is, while it seems that I've fixed my idle problem, and my acceleration on top of that, I do feel some hesitation when accelerating. When the truck is going through the gears it just feels sluggish, as if it's underpowered. The car/engine does vibrate somewhat. I did...
  19. C

    Explorer dies at a complete stop

    Update: Yesterday my CEL came and got the codes: P0506 (IAC circuit condition or idle speed higher/lower than expected), P0102 (Mass or Volume air flow "A" circuit low) , P0113 (Intake air temperature (IAT) sensor circuit high input) P2106 ( Throttle actuator control system - forced limited...
  20. C

    2004 Explorer V8 accelerator pedal problem

    What Number4 suggested is exactly what I did today. I didn't take out my entire throttle body, but I took out the part with the butterfly valve and the throttle position sensor. It was caked up with oil residue badly, and so was my throttle body. After giving them both a good cleaning with some...
  21. C

    Explorer dies at a complete stop

    Update: I changed 3 more spark plug, entire right side is done and I have two more to go on the left side (even with the air intake off the upper two on the left side is a ***** to get to) All seemed well when I started it up, RPM's were at 1k, when driving around my apartment complex it...
  22. C

    Explorer dies at a complete stop

    Here's my update: Dumped a can of seafoam in my gas tank (it's a full tank) Cleaned MAF sensor Cleaned IAC Valve Since I was strapped for time, I only replaced 3 spark plugs on the right side (1 had a bunch of stuff in the way, no time) Since leaving work 30 minutes ago, my car died...
  23. C

    Explorer dies at a complete stop

    I've got the spark plugs. Tried removing one and it was stuck! Granted, I tried this after the car was already warm. I screwed it back in and all is fine I guess. I'll tackle this job tomorrow morning as I have work. Will post results.
  24. C

    Explorer dies at a complete stop

    I don't have any check engine lights, but it could be that. I remember I started to hear some kind of whistling noise when accelerating months ago, but completely shrugged it off. Problem is, I can't find that elbow, my pcv valve or my iac valve. I've looked up pictures of other 4.6L and...
  25. C

    Explorer dies at a complete stop

    Continuing from my last thread, the Explorer starts and runs fine now, but will die when coming to a complete stop unless I quickly put it in neutral. It starts up, granted I have to put my foot on the gas for it to get going. After that, it just keeps dying at complete stops, which is obviously...
Back
Top