Search results | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Search results

  1. A

    1998 explorer no power to windows or 4x4 after engine start

    Problem solved!! My negative battery cable was loose. Thanks for the quick advise:)
  2. A

    1998 explorer no power to windows or 4x4 after engine start

    My explorer has started losing power to windows and 4x4 when i start the truck.It all work fine in accessory then it stops working when I start it up. Help please.
  3. A

    Front brake shudder

    have you had any luck with this problem? I am having a similar problem on my 95 Ford Explorer and just changed my pads and rotors thinking it may be the pins sticking but was not sure.
  4. A

    1999 Frod explorer 4.0 SOHC 4x4 thermostat housing replacement--how?

    I know when I bought my 98 explore that the thermostat housing had a leak in it. if I remember right taking the thermostat housing off required removing the air intake and upper intake manifold.
  5. A

    New Explorer "Crucial" to Ford

    I think that Ford should have just let the Explorer name die instead of slapping it on a car. I agree hole heartedly!!! I have no problem with the new ex exept thats it's just not and ex just give it a new name and don't confuse it with a true S.U.V !!!:salute:
  6. A

    Transfer Case Which Years

    hey sound like what mine started doing right before it failed all together
  7. A

    Please Help! Whining sound coming from drive train during deceleration

    update just an update the t-case whine off and on for months, got better after i changed the fluid! but finally kicked the bucket today:( Was only able to get it home by driving in 4 low for 15 long miles at 15 to 20 mph just under 2000 rpms. Now for the the fun but dreaded trip to the junk...
  8. A

    Anyone in Indiana???

    New Palestine here
  9. A

    Please Help! Whining sound coming from drive train during deceleration

    I have a whining sound that sounds kinda like a drill but much louder coming from under my x. I only hear it when a release the throttle from speeds over 55 mph. It will stop if i touch the gas and start back up when i release. My x is a 98 sohc v6 4x4 control trac with 4a/4h/4l. Any ideas? Is...
  10. A

    help 1995 x not runing right

    i have a 95 explorer 4.0 4x4 with 188,000 miles and last week it started missing now it's runs rough when in gear with brakes applied here are the codes i have so far koeo 335 (O) EGR feedback signal is/was out of range cm codes 13 (O) ISC did not respond properly (extends to touch throttle...
Back
Top