Search results | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Search results

  1. B

    engine stalling and sputtering, lack of power

    changed the fuel pressure regulator and the throttle position sensor, still doesn't idle quite right after a hot start, seems better though...
  2. B

    engine stalling and sputtering, lack of power

    nm i found this post with the info on where it is lol
  3. B

    engine stalling and sputtering, lack of power

    vacuum lines look bone dry from what i can see, where is the fuel pressure regulator located? i can just swap the one from my parts truck to see what happens.
  4. B

    engine stalling and sputtering, lack of power

    Ok, changed the IAT sensor, cleaned the MAF sensor, unhooked the battery after for an hour. Still no luck. I'll check the vacuum lines tomorrow its getting dark here. thanks for help so far guys, starting to rule stuff out now :)
  5. B

    engine stalling and sputtering, lack of power

    so I just changed both sensors, the ect and the one right beside it, did some hot starts and it started great, got home and let it sit for about 20-30 mins and started it, and then it idled like poop :( i didn't check the thermostat cause the one it the parts truck was done anyways, plus this...
  6. B

    engine stalling and sputtering, lack of power

    ok thats the engine coolant temperature sensor? i have a parts truck so i can just plop that one in and see what happens
  7. B

    engine stalling and sputtering, lack of power

    Also there is no engine light on, hasnt been on since i changed the MAF sensor
  8. B

    engine stalling and sputtering, lack of power

    so i fired it up this morning, started fine other then a couple extra rotations, and drove fine, full power. so its definately a hot start issue, at least one issue is. went to crappy tire and found a fuel pressure tester. my truck is a 1993 explorer with the 4.0 v6 auto trans and auto t-case...
  9. B

    engine stalling and sputtering, lack of power

    thanks for the reply guys, ill see what i find out today and ill let you know, and ill check for moose fur lol
  10. B

    engine stalling and sputtering, lack of power

    Hi guys, just wanna say that this site has helped me get my explorer back on the road\offroad more then once, so thanks for all the great walkthroughs and posts. So here's my latest problem, for the last year or so, when the truck is started right after being shut off it kinda runs crappy for...
Back
Top