Search results | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Search results

  1. B

    plug change went horribly wrong

    How did you know, bluestream1? Yeah, that was one I did NOT try to do myself. I even had a couple of local mechanics turn it down. It's on it's 2nd transmission (third technically, but the second one died under warranty shortly after it was installed), fourth alternator, original rear end...
  2. B

    plug change went horribly wrong

    Update---and thanks for the help Thanks to everyone for all of the helpful suggestions. I pulled the passenger front tire and removed the plastic inside the wheel well, giving me much better access to the port. I was just going to put a new plug in as best I could and attempt the thread...
  3. B

    Advice on rear wheel bearing/rear end replacement

    99 XLT 4x4, > 300K miles. The original rear end has been on her last leg for some time, and I think that leg is broken now. The driver's side wheel bearing seal has ruptured. That axle currently has an axle-saver bearing on it...which was installed probably two or three years ago. I...
  4. B

    plug change went horribly wrong

    HunterDan, It's the 4.0 SOHC. Of the three cyls on the passenger side, I think the one in question (the front), is the most accessible. But whether or not it is accessible enough to be drilled and tapped...who knows. I'll try the chaser and see what happens. The top side looked pretty smooth...
  5. B

    plug change went horribly wrong

    OK, I'm feeling better about this...thanks for all the replies. Is anyone familiar enough with this vehicle to know if this operation is possible without pulling the engine? I surveyed the damage pretty easily by pulling the front wheel...not sure if there's enough room for a drill. Maybe a...
  6. B

    plug change went horribly wrong

    This may have been an ungraceful end to my 99 XLT, 320K miles. My son has been driving it for a year or so, and he decided to change spark plugs. Cross-threaded plug #3...passenger side front-most plug. Stripped the !#%!@ out of it. Plug is in, but at an angle; I can see a tiny bit of...
Back
Top