Search results | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Search results

  1. C

    A little lost - 98 Mach stereo - subwoofer

    OK, so it's gone. Now what? I guess I can search for a factory amp for sale on here or Ebay, but is there some cheapo Wal-Mart one I can pick up or something to get it to work again?
  2. C

    A little lost - 98 Mach stereo - subwoofer

    I read the sticky here, but I'm still a little confused. Should the stock MACH subwoofer have its own amp, near the subwoofer, or is the amp behind the head unit? Our subwoofer has never worked since we bought the truck used, and I'm not sure if it's blown or if the amp is missing. Help?
  3. C

    Running aftermarket shocks now - is there a way to disable the "Check Air Ride"?

    I just wanted to say that I did this "mod" this weekend and everything went smooth as silk. Took about 10 minutes total, and I was triple checking everything. I ended up just cutting the 2 wires about 4 inches out from the back of the message center and capping each wire. This way if need...
  4. C

    Running aftermarket shocks now - is there a way to disable the "Check Air Ride"?

    lol, I was like "huh?", then I went back to the original posts. I hope you took my jab in stride...I was just messing around. I'm not too active on this board but I'm familiar enough with "searching" and looked and looked on this board and others first. Seems like the answer is here now...
  5. C

    98 EB V8: manifold leak? "sound" during accel

    I'm going to check and see if that's what it is, and if so, I'll probably be sending you a PM...thanks!
  6. C

    98 EB V8: manifold leak? "sound" during accel

    OK, thanks...I'll check it out.
  7. C

    98 EB V8: manifold leak? "sound" during accel

    Well, $200 each isn't bad IF that really is the problem...I'd hate to pay $400 especially to replace stock for stock only to find out that wasn't the issue. Is there a way to test this?
  8. C

    98 EB V8: manifold leak? "sound" during accel

    I just replaced the plugs and plug wires at 102k miles, figuring that was causing the sound, but no go. It does drive better, but I still get a te te te te te te te sound when cold or from a stop light. When warm it goes away. It's like the sound of a go kart taking off. I'm wondering if...
  9. C

    Running aftermarket shocks now - is there a way to disable the "Check Air Ride"?

    Sweet CougarX and yamaman101, I came back here just to check some things and saw the diagram, etc. I'm going to make the changes this weekend, woohoo! So with the diagram, am I assuming right that I basically just lay on the driver's side and look behind the center console, then find...
  10. C

    98 EB with 5.0 V8 - hesitation and CEL blinks

    Thanks! I went by Autozone at lunch and found the Bosch platinum plugs on sale for $2.18 and they have a $1 rebate each, so around $10 for 8 plugs AR ain't bad. I went with the regular Duralast (autozone) wire set too for $49. The Bosch set was $62. So decent deal overall.
  11. C

    98 EB with 5.0 V8 - hesitation and CEL blinks

    OK, so a simple trip to Autozone or simliar will do and just about anything they sell is fine? I guess the better question is, any particular brands or styles to avoid? I just want a stock running truck, nothing fancy for the misses.
  12. C

    98 EB with 5.0 V8 - hesitation and CEL blinks

    Thanks! Any recommendations on plugs and wires? Or maybe a link here? I called the local Ford dealer and they want $8.27/each for Motorcraft plugs, the coil is $121 and the wire set is $217. That's just crazy, when I can find Bosch plugs for $2.20 each, etc. But I want something...
  13. C

    98 EB with 5.0 V8 - hesitation and CEL blinks

    We have a 98 Explorer Eddie Bauer with the 5.0 V8, it has around 102k miles. Lately it's been hesitating pretty bad during medium acceleration, especially when cold, and yesterday we went out of town (160 miles) and with cruise control on, when we went up a hill on the interstate the CEL...
  14. C

    Car Alarm help - aftermarket

    Thanks all, the12volt was where I also posted, and they hooked me up. And you both were correct... A+++ would post again! :D
  15. C

    Car Alarm help - aftermarket

    Wasn't really sure where to post this..but I figure the guys/gals that know car audio probably know security as well. I have a 98 explorer with either an upgraded stock or aftermarket alarm w/ remote start. Problem is I don't know what alarm it is...but I know it's probably a cheap one...
  16. C

    Running aftermarket shocks now - is there a way to disable the "Check Air Ride"?

    Figure I'll bump this again and see if anyone knows yet. The exact message when starting the explorer is: "Air ride switch off" which makes sense, since I turned it off. But I'd like to not get the message everytime I start the thing. Things I've tried: Removing 1 at a time, the...
  17. C

    Running aftermarket shocks now - is there a way to disable the "Check Air Ride"?

    You sure about that? Better check again. The guy in that thread is asking the same question I have (his last post). Nobody responded with an answer. C'mon Doug, get pissed and prove me wrong...(I need the answer worse than the e-rep...:) )
  18. C

    Running aftermarket shocks now - is there a way to disable the "Check Air Ride"?

    I did search. How about being helpful if you know the answer? Having a 2 word reply with a 90 word signature doesn't help me any, thanks. Or tell me what to search for because the following didn't work: DISABLE AIR RIDE AIR RIDE DISABLE AIR
  19. C

    Running aftermarket shocks now - is there a way to disable the "Check Air Ride"?

    I replaced the stock air ride shocks since they were really bad, and disabled (turned off) the air ride. Now every time we start the Explorer the "Check Air Ride" error comes on. Is there a way to completely disable this? I saw in the owner's manual there is a fuse for the suspension...
  20. C

    Blee1099

    Blee1099, Ben, did a wonder for me! Local dealership wanted $125 for a part. Ben hooked me for $25. Excellent transaction...I'll be sure to PM him first the next time I'm looking for something.
  21. C

    Subwoofer in mach system...no sound...audio n00b

    Guys, We've had our 98 EX for about 4 months now. The weather is decent enough for me to go out and tinker around now, and since the subwoofer has never worked since we've had it, I figured I'd take a look. The subwoofer is there, but wasn't connected to anything, and there was a white...
  22. C

    Spare tire stolen...part needed!

    no cable looks good, it definitely looks like it was cut. Will I need the full assembly or just the cable and tire mount?
  23. C

    Spare tire stolen...part needed!

    The local dealership is closed and motorcraft.com doesn't list anything for this. I just bought our X and the guy said it didn't have a spare so he ordered a replacement one. Well, while replacing the shocks I noticed that they must have had the spare stolen off the lot or something because...
Back
Top