Search results | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Search results

  1. T

    Rough Idle Misfire Cold start no codes.

    I don't think so. No visible drips, no white smoke and no water in the oil. Why, how would a coolant leak effect this problem?
  2. T

    Rough Idle Misfire Cold start no codes.

    Hi my98nnj and thanks for the reply. I haven’t checked the resistance across the ECT sensor yet but I put the scan tool on her today and noticed that before starting the engine the water temperature was reading almost 30 degrees higher then both the Intake Air Temperature and the ambient air...
  3. T

    Rough Idle Misfire Cold start no codes.

    My 2000 AWD 5.0 with 120K starts fine but when I start driving it sounds like it's running on only 4 cylinders. There is no power and it backfires as I try to give it more gas. Within 5 minutes or so things smooth out to almost 100% it is still a little rough when I stop at a light for instance...
  4. T

    low oil pressure issues

    I replaced the oil pressure sensor on my 5.0 with a unit I purchased from NAPA. The thing worked for about 3 weeks. Then the gauge started to bounce around so drastically and so erratically that the needle somehow went past the peg on the gauge! I replaced the sensor again with a Motorcraft...
  5. T

    Opinions needed on alignment issue-Brackets cut for mechanic's access???

    Is the guy who originally cut the brackets still employed?
  6. T

    Opinions needed on alignment issue-Brackets cut for mechanic's access???

    Has there been any resolution? I just took my truck for an alignment and mentioned this to the service writer and he didn't believe it. I made sure to check the upper control arm brackets on my truck before I left the shop! I'm well aware of all the things some of these butchers (pun...
  7. T

    Is this stock?

    Thats the mount for the 5th shock absorber or laterally mounted vibration damper. It is mounted more or less horizontally from the rear diff to the frame. Many run with it removed. Many say it"s there for a reason. Personally I'm in the "it's there for a reason" camp. More here.
  8. T

    Need advice from professional detailer

    Well If that's the recipe for "Ford" New Car Smell I'm going to bottle it and sell it on TV! I'll make a MINT!:D
  9. T

    Attn all "Growling" x's!!!!

    This site is great and I'm one of those guys who changed everything up front BEFORE looking at the prop shaft for my growling noise!
  10. T

    Attn all "Growling" x's!!!!

    This should be a sticky!
  11. T

    (Front) sway bar links

    Basically it's just a long bolt with rubber bushings at each end separated by a spacer. I think I jacked up the truck a little just to make it easier to get underneath but it's probably not necessary.
  12. T

    (Front) sway bar links

    The sway bar links are real easy to replace. The most difficult part was removing the old ones. I used a angle grinder to cut the old ones off. Here's a good write up w/pix on the subject.
  13. T

    Shocks

    I just installed Monroe 37122 Sensa-Trac's up front and 58617's Sensa-Trac Load Adjusting Shock Absorbers in the back of my 2000 Mountaineer. I was very pleased at how well the helper springs on the 58617's lifted the rear of the truck. It’s at least 2“ higher and I’m very pleased with the ride...
  14. T

    cannot figure out vibration

    Same thing here on my 2000 AWD. It was the drive shaft. http://www.explorerforum.com/forums/showthread.php?t=353585
  15. T

    Front end growl / vibration fixed! Finally!

    Yes jremington59 and thank you. At that time, I already had most of the other parts already on the shelf. Except of course the driveshaft!
  16. T

    Front end growl / vibration fixed! Finally!

    Yes Curt, that's exactly how I consoled my self! But really, the ball joints were shot as were the shocks and one of the CV boots had a small tear. It was time.
  17. T

    Front end growl / vibration fixed! Finally!

    This question was really meant as a rhetorical question.
  18. T

    Front end growl / vibration fixed! Finally!

    For more then a year I’ve been putting up with an annoying and sometimes loud growl or rumble and vibration from what I thought was the front left side of my 2000 Mounty 5.0 AWD. I was absolutely convinced it was a bad wheel hub, and since I have 120k on the truck and no front end work had...
  19. T

    Radio display fix

    I'm in need of this repair. How much did it cost and how does one get hold of Trever.
  20. T

    Merc Mountaineer leaf springs

    I just installed Monroe 58617's Sensa-Trac Load Adjusting Shock Absorbers in the back of my 2000 Mountaineer. The original shocks had 120K on them so I figured it was time! I was amassed at how well the helper springs on these shocks lifted the rear of the truck. It’s at least 2“ higher and I’m...
  21. T

    Torque Values for 2000 Mountaineer Front end work.

    I'm doing some front end work on my 2000 Mountaineer AWD 5.0. I'll be replacing Hubs, CV axles, Upper & Lower ball joints, Tie Rods etc. I need the Torque Values for reassembly. I found this here for a 2004. Do these values apply for a 2000?
  22. T

    Radio LED display fix!!!

    Hey fifthranger thanks for the reply. I was under the assumption that if power was removed from the head unit it would "lock out" and require a code to unlock it. Some kind of security feature. I kinda recall the dealer talking about this when I bought the truck 12 years ago but I haven't been...
  23. T

    Radio LED display fix!!!

    Ok I know this is a pretty old thread but I have a question. If I remove the radio to clean and re-solder the circuit board and it DOESN'T work wouldn't I have to enter the code to unlock the radio? And is it possible to enter the code without the benefit of the display? A radio with no display...
  24. T

    Growling, grinding noise from front end

    Thanks jremington59 I will check it out!
Back
Top