Search results | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Search results

  1. T

    A/C Cold on Passenger Side, Hot on Drivers

    Hi All... Several years ago, this forum helped me with my blend door problem - the large center one. The tab had broken (as is common) and got great help here on how to DIY a fix. All's been good until a couple of days ago. Now the A/C is blowing cold on the passenger side vents (round one by...
  2. T

    Chrome Flashing on Grill

    All sanded and ready. Did you wipe the grill down with anything like mineral spirits or use a plastic primer? Also, bed liner spray did you use?
  3. T

    Chrome Flashing on Grill

    Thanks, Bob - looks exactly what I'm looking for. Did you pull the grill or just take your time with it in place?
  4. T

    Chrome Flashing on Grill

    The chrome flashing on my 2007 Explorer is peeling off and I'm looking for ideas on what to do. The rest of the vehicle is excellent and this really bugs me. The vehicle is white with black trim and I thought making the grill black might look nice, but how would I get all of the chrome crap...
  5. T

    Shock - When to Replace

    Sounds like it would not be a bad investment since I plan to drive it for a while. Now the question is: MOOG, Monroe, KYB, Bilstein, Rancho, etc.?
  6. T

    Shock - When to Replace

    Sounds like it would not be a bad investment since I plan to drive it for a while. Thanks everyone.
  7. T

    Shock - When to Replace

    Hi Everyone... My 2007 XLT Explorer just turned 100,000 (4.6L, AWD). Tire wear is fine, steering is good and no signs of any leaks around the shafts/housing. It does seem to bounce a little more that it used to, but that may be because I'm thinking about it and perception is off. If I push...
  8. T

    Airbag Light Always On

    I haven't done anything yet. The Passenger Airbag is Off light is lit when I start the vehicle, but goes out right away, no matter who or what is/is not in the seat - always off. One thing I am concerned about replacing it myself - does anything need to be recalibrated after installation...
  9. T

    Airbag Light Always On

    Resurrecting... I disconnected the yellow plug under the passenger seat, cleaned, added a little dielectric lube and reconnected to no avail. Spent the $$$ to have Ford diagnose here's what the printout reads: DSGEN VEHICLE NEEDS THE RIGHT FRONT OCS SENSOR/RAIL REPLACED FOR AIRBAG ISSUE...
  10. T

    Fuel Rail Pressure Sensor Location

    Running rough and hard start. Check engine light came on. Caught a P0193 code. Battery, fuel level, fuel pump, wiring all check out. Only 12,000 on fuel filter. Sensor was next - was not reading correct voltage. Replaced and all good.
  11. T

    Fuel Rail Pressure Sensor Location

    Thank Bill. Sensor replaced and the Explorer is running great.
  12. T

    Fuel Rail Pressure Sensor Location

    Can someone please tell me where the fuel rail pressure sensor is on a 2007 Explorer with the 4.6L V8? Thanks.
  13. T

    Airbag Light Always On

    I've read a lot of posts here about the airbag light and I'm going to try cleaning the big yellow connector under the front passenger seat (as suggested many times here). The light is always solid - no blink codes. It's a 2007 XLT with the 4.6 motor. Questions - disconnect the battery? If...
  14. T

    Coil Packs & Plugs

    Thanks, David. I really think I'll take the chance on the coil packs first - easy and hopefully the solution. BTW, how did your plugs look @ 80,000 - I'm not that far away! Tim
  15. T

    Coil Packs & Plugs

    I'm getting the low-speed, low-RPM jerk/misfire of a bad plug/coil pack on my 2007 Explorer (4.6 3V). I know my way around a motor pretty well, but the seized/broken plug issues on these Explorers scares the crap out of me. I've read TSB 08-7-6 and it's straight forward about the 1/8-1/4...
Back
Top