Search results | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Search results

  1. E

    Solved Torsion Bar 101, Everything you Need to look for!

    Not long Someone who has done theirs more recently can probably answer more specifically. I did mine back in 2002! Jacking up the vehicle and setting up the jack stands takes longer than the actual torsion twist though as long as they are not jammed, rusted or stuck. Mine took longer since I...
  2. E

    Solved Torsion Bar 101, Everything you Need to look for!

    Not badly Not badly, just more of a firm ride. I liked the ride better than stock. In fact I found that it helped with corning and emergency maneuvers. Does not hurt your load carrying ability either. A little more jarring at slow speed in the rough, but better at higher speed wash board runs.
  3. E

    Reviving my 95 finally after 2+ years!

    Thanks You are right. I'll regret it if I sell! At least I paid my Elite dues today! Gotta start somewhere...
  4. E

    Reviving my 95 finally after 2+ years!

    Back Thanks for the kind words! It has been a long time. Still not much progress on the beast. Fixed the large leak, but there seems to be more so the X has been sitting in the side yard waiting its turn to be worked on. At this point all of the vehicles are being neglected as we replace the...
  5. E

    Elite Explorer Stimulus Package!! 4 years for price of 2 + goodies!!

    Bummer E-mail went to my junk file and missed this offer! Actually had to put the X in the side yard behind the fence to avoid the HOA police... out of sight, out of mind including checking the web site... Bummer.
  6. E

    Reviving my 95 finally after 2+ years!

    O-Ring That's the one! Thanks ranger7ltr! Time for a trip to the dealer.
  7. E

    Reviving my 95 finally after 2+ years!

    Dart Wow. That's serious beast you are building! I'll have to come over and see it.
  8. E

    Reviving my 95 finally after 2+ years!

    Late in the day! Yes, I need to figure it out quickly as Carla test drove a Wrangler Unlimited yesterday and after 2 years parked its getting harder to justify keeping the X. Hoping someone has the answer to the gasket/o-ring question as nothing similar came in the gasket kit that I bought when...
  9. E

    Reviving my 95 finally after 2+ years!

    Leak Finally got back into it. Found a huge vaccum leak where metal tube running from what I think is the PCV (or EGR?) valve sits right over the driver's side exhaust manifold. Does this tube use some sort of gasket or rubber O-Ring where it fits into the upper intake manifold? I had...
  10. E

    Reviving my 95 finally after 2+ years!

    Back to Square 1 So almost the same results with a new MAF. Runs (rough) on its own if MAF disconnected, but barely runs with MAF connected. Seems to be just a little better with the new one, but not enough to justify the expense. With truck running and MAF disconnected the exaust is very...
  11. E

    Reviving my 95 finally after 2+ years!

    I appreciate the suggestions and it was definitely worth taking another swing at the cleaning if it could save some dough! Weird how all these parts that worked fine 2 years ago now are bad from just sitting... fuel pump, guages, maf,...
  12. E

    Reviving my 95 finally after 2+ years!

    Cleaning Well, I pulled the plug that had the non firing wire. The ceramic was cracked. Replaced it and the motor runs without the pop. Without the MAF hooked up it runs rough, but runs. Idles about 1400 and stays running in gear. Went to Radio Shack and bought the Electronics Cleaner...
  13. E

    Reviving my 95 finally after 2+ years!

    MAF Cleaning I did one more cleaning with CRC MAF Sensor Cleaner. Think there would be any benefit from making a radio shack run for the electric parts cleaner and cleaning it again? Going to change the plug and see if I can at least eliminate the popping. All plugs black and sooty now...
  14. E

    Reviving my 95 finally after 2+ years!

    Any chance it could be a bad computer signal or other? Hate to spend another $100+ on another part if not necessary... Can they be repaired? Is it worth going to a junk yard or do they have a definite shelf life?
  15. E

    Reviving my 95 finally after 2+ years!

    Maf So I read back through the suggestions and tried Rick's idea of disconnecting the MAF connector. Started right up! Still runs rough from that #5 cylinder. I connected the MAF while it was running and it ran more smoothly. I could even put it in gear and it ran. Weird thing is that when...
  16. E

    Reviving my 95 finally after 2+ years!

    Plug? Would a single bad plug keep it from starting? I know it would contribute to the popping. Checked the firing order and checked plug wires. At first it seemed as though only #1 and #4 were firing, so I thought the coil pack might be bad, but all but #5 are firing now. If I run the #5...
  17. E

    Reviving my 95 finally after 2+ years!

    Sea Foam I'll give it a try. At this point I'd do a sea foam dance if it would make a difference! Thanks.
  18. E

    Reviving my 95 finally after 2+ years!

    No luck Took a couple tries to get the correct unit with the correct connector. Of course, mine was the more expensive one! No luck though. It won't start now at all. Back to the drawing board.
  19. E

    Reviving my 95 finally after 2+ years!

    The Seafoam is what toasted the IAC. Helped the MAF I think though. Have new plugs and injectors, but probably time for new wires. Noticed that you are from Alaska? Beautiful state. Have been to the Anchorage area a few times for work. Wish your Gov. would have made the VP spot!
  20. E

    Reviving my 95 finally after 2+ years!

    Fuel System Fuel System should be good to go. New fuel pump and filter. Although since the truck has been idle, the needle on the indicator seems to be stuck at "F"...? All the other gauges seem to be working. Strange how the fuel pump went bad just sitting there and now this rough running...
  21. E

    Reviving my 95 finally after 2+ years!

    Hi Rick, If it was not the IAC before, it is now after I tried to clean it... Only idles now when the IAC is disconnected. Going to let it dry out and see if it works again in the AM. If not, I'll get a new one and see where we stand. Don't understand the popping though. Checked the plug wires...
  22. E

    Reviving my 95 finally after 2+ years!

    Worse! Well, the engine idled (mostly) after some cleaning of MAF. Still very rough and popping. Won't rev smoothly either. Tried to clean the IAC but made it worse! Then would not start at all. Disconnected connection to IAC and now it will idle but dies upon any kind of throttle touch...
  23. E

    Reviving my 95 finally after 2+ years!

    Hey Rick! That's really funny. HI to Char from Carla. Its Rick by the way! We're closer to you now (if you have not moved...) We are at 43rd and Grovers. The Explorer has not changed a bit from when you last saw it except that its a storage bin...
  24. E

    Reviving my 95 finally after 2+ years!

    Fuel Pressure Pressure at 40psi at 1500rpm. Drops to 35 range at lower rpms. Starts right up on first turn but even at 1500 it is rough and pops. Need to hold pedal at 3/4 down to keep it steady. Anything less and it begins to die.
  25. E

    Reviving my 95 finally after 2+ years!

    Finally trying to get back in the game. The X has been waiting patiently in the garage for almost two years. Put on rebuilt heads after an injector failed and a lean condition ate a plug and spit it out a valve. Pistons seemed fine and no scoring on walls. When I first got it back...
  26. E

    Help: Need to buy cylinder heads... Where?

    I did get the heads. I am not sure about the quality yet as I just found the time to install them. Still need to complete intake installation. The company tried to charge me for both cores saying that they were both cracked, but when I asked for both back, they called back saying that only one...
  27. E

    Help: Need to buy cylinder heads... Where?

    Heads Try Bill's Cylinder Head in Phoenix, AZ The phone number is 602-278-6636. They were referred to me by Rick H. and Mark S.. I paid $199.00 for the pair plus $300.00 core charge. The address is 1620 S. 27th Avenue Phoenix, AZ 85009-6421. I don't think they have a web site. Can't vouch for...
  28. E

    Torsion Bar Adjuster Bolt Broke HELP!!!!!

    LockTite Mine has broken twice... The first time on the trail during a run with the group, and the second on the street. The second time I was in the same situation as you are. I found two nuts that fit the bolt used lock tight and put them on together so that they "bound" together and when the...
  29. E

    Comment by 'ExplorGM' in media 'AZ Run 2002'

    Thanks for the compliment. It has a 3" body lift from a 97 Ranger or previous generation X. I can't remember which right now... I'll see if I can get the part number. Try a search of the web site. That's how I originally found out which part number to use... Torsion twist in the front with...
  30. E

    OD Problem 4th time in two years!

    Several questions... 10/15/02 at 137202 miles my tranny gave up. OD light flashing, tranny would not engage above 1000 rpm, finally would not go at all. Had it rebuilt ($1823) with 12 month, 12K warranty. Kens Transmission on Bell in Phoenix. After one month the same OD light flashing problem...
  31. E

    tranny upshift problem - mystery

    Tranny Sounds similar to the problem mine is having now. Its been in the shop three times for this.Twice after being rebuilt... The overdrive pump blows a seal and on mine the OD light flashes after a while and the truck does not want to shift up.
  32. E

    Major issue!! Tranny fluid in motor?????

    I am hoping that's all it is. A new Radiator is a lot cheaper and easier to replace than the alternatives. Can't seem to get away from these darn radiators... In fact, I just installed three J**P radiators this weekend so I'm starting to smell like Low-Tox... I can't think of any other entry...
  33. E

    Major issue!! Tranny fluid in motor?????

    Tranny fluid in radiator coolant I have a similar problem. My radiator overflowed on Friday and it came out pink... Judging by the color and smell, it was tranny fluid. I thought maybe I had blown a main seal or ruptured the radiator, but it would sure be nice if it was something as easy as a...
  34. E

    Good resource for researching GPS Coordinates/Trails?

    Thanks Brian Thanks, I'll check it out.
  35. E

    Good resource for researching GPS Coordinates/Trails?

    Start- 30-50-09 North 111-57-09 West Finish- 35-07-48 North 112-32-36 West What would be a good resource for researching trails that might connect these two points? They are in AZ, Phoenix to a cabin up north...Is there a locater web site that anyone is aware of for using these...
  36. E

    Do the Cats needs replaced ?

    Passed! Well it passed. It still has a misfire at idle, but the test they ran was a 28 second test at high RPMs. I did have to take it back a second time to have them test it as they would not test it even with the exaust extension that I had put on it. Said it was still too close to the...
  37. E

    Do the Cats needs replaced ?

    Old results comparing AZ and CT... Interestingly the truck passed in 10/27/2001 with these results: HC-.10 Max limit 1.60 CO-3.78 Max limit 20.00 NOX-.97 Max limit 3.00 AZ tests in Grams/Mile When it was done in CT on 4/10/01 these were the results: HC-2.7ppm Max limit 151.0 CO-.10%...
  38. E

    Do the Cats needs replaced ?

    Thanks Mark Thanks Mark! From the web site, it looks like they'll put it through the full test. This might be a dumb question, but if the mixture is running rich, wouldn't the "check engine" light come on with a resulting error code?
  39. E

    Retorqueing the manifold bolts.....

    Inch lbs...!! Thanks Bracken53! That will teach me to read more carefully... So far I have only hand tightened them down with a small ratchet. I need to get an adaptor to fit the 10mm to my torque wrench. Should be interesting to see where they are at now....! They were pretty loose to begin...
  40. E

    95 eddie OD light flashing

    Just went through the same problem twice I had my tranny rebuilt 10/16/02 and a week later the overdrive light started flashing and I lost OD. They said it was a seal that came loose/flipped and also that the sensor was bad. A year later with less than 10 days and less than 500 miles on the...
Back
Top