Search results | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Search results

  1. D

    Blow off valve 2.3

    I looked and felt and didn't see anything out of the ordinary. Only happens when turbo really spools. Normal when in neutral or easing on gas to get to speed. It still has boost just not all of it. I know it had wastegate clip problems but it is still attached. Just trying to see if it's...
  2. D

    Blow off valve 2.3

    Does anyone know where the blow off valve is on a 2016 2.3 eco? When the turbo spools now. It sounds like a loud exhaust leak and it's low on boost. Only have a p0420 code which has been on and off intermittently. I don't get any wastegate or turbo codes I don't see any hoses or anything...
  3. D

    Transmission mount bolt

    I thank all of you for brainstorming on this. i believe the bolt was over torqued. but its gonna be me against them. if they removed the trans i would have to believe they removed the bolt. I am on my way there now to see how much further i can get with them
  4. D

    Transmission mount bolt

    The dealership did say it was a 2 year warranty. Problem is , they don't wont to honor it. I am just gonna escalate it to ford and see what becomes of it.
  5. D

    Transmission mount bolt

    Here's a strange one for you . I had the Customer Satisfaction Program "20N07" done to my truck Sept 2021. Comes with two year warranty according to service advisor. 2 days ago the transmission bolt that mounts to motor broke in half. Which in turn damaged all motor mounts, which dropped the...
  6. D

    Engine Stalling

    Update #2 over 1000 miles and not a hiccup
  7. D

    Engine Stalling

    Well I replaced the fuel injection pressure sensor and haven't had a problem yet 400 miles later. Response seems better, gas mileage is better. So far fingers crossed
  8. D

    Engine Stalling

    Hello everyone, first post here. I have a 2016 explorer limited 2.3. 130,000 miles. I got the car with 106000 miles and it's been a problem ever since. I bought it and took a 2600 round trip 2 days later in it. Upon getting 60 miles from the house on the way back, it started shaking a little...
Back
Top