Search results | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Search results

  1. K

    Abs codes.

    I have pulled my fuses for the 4x4 because it was constantly engaging, not sure if that would have anything to do with the number of codes, but I'll start with checking fuses. Thanks
  2. K

    Abs codes.

    I finally bought a scanner to pull my codes for an ongoing abs issue and come up with the following. U1900 ( communication bus fault 2), c1234 (RF speed sensor input signal missing), c1175 ( LR speed sensor input circuit failure), c1165 (RR speed sensor input circuit failure), c1440 (...
  3. K

    Another ABS thread

    Ok i will check that one of these days when the rain quits, will also look around for someone to pull codes. Thanks.
  4. K

    Another ABS thread

    No i tried to have AutoZone do it but they said they couldnt.
  5. K

    Another ABS thread

    Ok got an 04 xls 4x4 104xxx miles. Abs light is always on and often engage when stopping, which also was i think causing 4x4 to kick in and had 4x4 lights on. Ive pulled fuses from 4x4, changes both front hub bearings and all 3 speed sensors. Abs still illuminated and engaging. Any ideas? (All...
  6. K

    heat blowing cold

    Ive got an 04, yesterday after sitting over night the heat now is cold. I replaced the blend door actuator a month ago and can see it moving when moving the position dial, the engine heats up to normal range fine, and both hoses to the heater core are hot. There is no noise when turning the dial...
  7. K

    belt dust?

    Update incase anyone else ever has this problem. checked the harmonic balancer and it seemed ok. at some point before i bought it someone must have changed a pulley and put a smaller one on, i noticed my tensioner was barley being used by the belt, so i ended up buying a belt one size smaller...
  8. K

    belt dust?

    ive got an 04 xls 4.0. there is a lot of rubber dust build up mostly around the tensioner and caked all over the alternator. it was a new alternator (which i think cooked because the thick rubber build up on it) and the belt is only a couple months old. the tensioner seems like it has plenty of...
  9. K

    serp belt fitment ?

    ahhh thank you very much. i dont understand why they done this but now i know.
  10. K

    serp belt fitment ?

    i just got a good year belt #4060865 for my 04 4.0 but its to long, ive looked at other brands specs and some are 85.5 some are 86.5". im sure i had it routed right because i put the old belt back on the same way, also my tensioner seems to be working properly. i ordered it online or else id...
Back
Top