Search results | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Search results

  1. 0

    Continuous P0401 Code - 2008 Explorer 4.0L

    I thought I would post a solution to my issue. I finally gave up and took it in to be diagnosed. They said the DPFE was faulty! This is the second (after market) EGR that I had on it. So, I returned it and bought a Motorcraft EGR from Ford. Guess what? No more codes. All monitors have...
  2. 0

    Continuous P0401 Code - 2008 Explorer 4.0L

    Hi All, I continue to get the dreaded P0401 code after several 'fixes'. Here is what I have tried to alleviate this issue: - Replaced the EGR - single unit that has the sensor and solenoid on top. - Replaced the vacuum houses from the EGR to the intake manifold (the old ones were...
  3. 0

    Rough idle after EGR replacement

    Hey guys. Problem resolved (for now). This latest issue was caused by an intake gasket not being seated properly. When I removed the intake manifold tonight, one of the six gaskets was laying on the top of the block. Once I replaced it, put everything back together (I also took advantage of...
  4. 0

    Rough idle after EGR replacement

    Ok guys. Need your help once again. To continue the story.... I sucked it up and purchased the vacuum assembly from the dealership because the break was so close to the boot that there was no way to splice it. So, after getting the new tube assembly, I noticed that all connections would be...
  5. 0

    Vacuum harness part number....need help!!! engine light on with wrench

    I know this is an old thread but did you ever find a 'how-to' on replacing the vacuum lines? One of of the lines broke next to the boot on the back of the EGR this weekend when I replaced the EGR. If you can provide any info on the replacement, I would appreciate it.
  6. 0

    Rough idle after EGR replacement

    sorry for the long delay - holiday time... Anyway, I had a guy with a nice OBD II connect to my truck and he determined that the new EGR was sticking open a little and causing the rough idle. I took off the new EGR and swapped it for another. It is running much better. However, I have a new...
  7. 0

    Rough idle after EGR replacement

    I disconnected the battery overnight and then took it for a 30 mile drive today (while making several stops). It did not seem to change anything and still idles rough. One of my stops was to Home Depot where I picked up a propane torch. I tried unsuccessfully to make the engine increase...
  8. 0

    Rough idle after EGR replacement

    Thanks fordbluefamily. Other than the having it disconnected during the EGR replacement, the battery has not been disconnected for any length of time. I will disconnect it over night and see how it is tomorrow.
  9. 0

    Rough idle after EGR replacement

    I tried finding a leak with water while the engine was running to now avail. Is there any other 'home remedies' that I can try before purchasing a propane torch?
  10. 0

    Rough idle after EGR replacement

    Thanks Steve. As I do not have a propane torch handy, I will either need to find someone who does or look for alternatives. I do have carb cleaner but am a little nervous about using something flammable like that (as I have seen suggested on the interwebs).
  11. 0

    Rough idle after EGR replacement

    Hello everyone. First time posting. I have a 2008 Explorer with the 4.0 that started throwing the P0401 code. I decided to replace the whole EGR assembly because the sensor and solenoid are all connected. The removal was not too bad (bolts were a bit tough to loosen and there was not much...
Back
Top