Search results | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Search results

  1. L

    spongy brake

    Watch out for terrible mechanics. My truck did not have front brakes. I swap the brake pads on the front and the brakes improved. Be aware of bad mechanics. I hope this helps the community. Cheers.
  2. L

    spongy brake

    LOL. an anchor might not be a bad idea. The brakes turned spongy when all the lights went off. The mechanic told me he changed the brake fluid so I assumed he bleed the system. How was it done? I don't know. I'll ask about it. Thanks
  3. L

    spongy brake

    Hi everyone, My explorer has broken again. After changing the ECU, finally, I got the check engine light off. The ABS, traction control, brake, and RSC lights and chimes were on. I took it to the mechanic and he changed the ABS module and the brake fluid. All the lights are off. Now the...
  4. L

    Module Repair

    Thanks for sharing the link. I'll take a look.
  5. L

    Module Repair

    Hi Everyone, I got a 2009 explorer xlt v6. I got a faulty computer. I live in NY long island. Does anyone know a place to fix the module? Thanks
  6. L

    P0135, P0141, P0155, P0161

    Thanks for sending the link
  7. L

    P0135, P0141, P0155, P0161

    I have been wondering if I should remove the EGR valve and clean it with brake cleaner fluid. I have not found a place to fix the ECU. do you have any keywords? Thanks
  8. L

    Can't find where the noise comes from

    Hi everyone. I found a threat here that solve my issue about the whistle noise. it is a vacuum valve for the A/C. Below is a link to the info. https://www.explorerforum.com/forums/threads/climate-control-vacuum-reservoir.371087/ good luck everyone.
  9. L

    P0135, P0141, P0155, P0161

    Hi Explorers. Thanks in advance for all reading this post. I have a 2009 explorer V6 XLT. I have codes P0135, P0141, P0155, and P0161. I check the sensors with an OBDII scanner and found that the upstream sensors were fluctuating a lot in voltage. I changed both upstream sensors with OE Bosh...
  10. L

    P0443 P0403

    hello Explorers. My 2009 Explorer XLT v6 has two codes P0443 and P0403. does anyone know why the codes got trigger? what do they mean? How to solve the problem? Any diagrams? Thanks
  11. L

    Can't find where the noise comes from

    Hello Explorers. My name is Rich. I am new to this forum. I have a problem with my explorer and I hope to find an answer to the problem in this forum. I have a 2009 XLT explorer V6 with 105K miles. The car runs ok (gas millage is ~10mpg city, I think it could be better). The check engine...
Back
Top