Search results | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Search results

  1. T

    Battery light

    I will try thanks.
  2. T

    Battery light

    My battery light keeps coming on. I put a new battery in, I have had the alternator tested and it was good. I do not know where else to look. Can any one help. Now the wrench keeps coming on. It did it today first where the radio is something came up where it said on the screen connecting then...
  3. T

    My 2006 Explorer is running rough

    ok so i pulled the codes again I pulled the codes again and it came back as cylender two random miss fire. I pulled the pulg and it was shot bad. the problem i have is the the pllugs where changed less than a year ago. i do not thing that they should have gone bad that quick. But non the less...
  4. T

    My 2006 Explorer is running rough

    thanks I will give it a try and see what happens
  5. T

    My 2006 Explorer is running rough

    I have a 2006 ford explorer with about 115,000 on it. It is a V-8 Eddi Bauer editon. 4 wheel drive. The porblem that I am having is it runs really rough. I have already changed the spark plugs and one of the coil packs. It started running when I put the Mid grade gas in it. I did some of my...
  6. T

    Just found the site and it has helped me a few times

    Ok my name is Toby Hood and I have been in the military for the last 17 years. The first explorer we owned ran great. It was an 03 ford explorer the only thing we had to fix was where and tear. This second one we have owned has cost me alot of money. When we drove it offf the lot it was not long...
Back
Top