Search results | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! Once registered you can join the Elite Explorers to eliminate ads from the website.

Search results

  1. J

    P2107, P0607

    The issue with the codes never resurfaced, but I re-taped up some wiring to the MAF sensor so I'm not sure if that was the culprit. Since then, I had an idling issue that would cause the vehicle to idle very low and almost stall. That turned out to be, what I believe, was an issue with a minor...
  2. J

    Powertrain Malfunction Light

    I went down this road before, and attempted to use an aftermarket TPS, which only made the problem worse. I ended up replacing the entire throttle body assembly with OEM Motorcraft, which came supplied with a new TPS. I wasn't able to get the old TPS off the throttle body, and it wasn't that...
  3. J

    Coolant pipe behind alternator

    Is this the part you’re looking for? https://parts.ford.com/shop/en/us/climate-control/heater-repair-parts/tube-auxiliary-heater-supply-7886381-1
  4. J

    Anyone got a part name or number for this hose

    You mean the old hose? It should come off the connectors fairly easy. If not, you could just cut the old hose off since you will be replacing anyways. I’d wear some gloves as the old hose will likely turn your hands black.
  5. J

    Axle seal leaks?

    Hi all. I’ve noticed what appears to be axle seal leaks on both sides of my 2008 Mountaineer 4.0L. Took a couple pics last night so I could post them. Does this appear to be the case or is it something else? I watched a video from Ford Tech Makuloco. He makes it look fairly easy to replace but...
  6. J

    tps plug found stripped wires

    So, for the 4.0l engines, is this the correct harness that needs to be replaced?: 8L2Z-12A581-BA
  7. J

    tps plug found stripped wires

    It’s not from bad factory work,it’s from using cheap wiring in critical system parts that just have not held up well over the years. Other folks here have experienced similar degradation of the wiring insulation in the same or similar areas that ultimately have resulted in all sorts of erratic...
  8. J

    tps plug found stripped wires

    These wires look just like those going to my vehicle’s tps before they replaced them. I don’t think anyone did this on purpose. Over time, the poor wiring insulation gets brittle and breaks and where the wires bend, the insulation falls apart. The other day, I noticed my EGR valves electrical...
  9. J

    P2107, P0607

    Mechanics’s report says the codes they pulled that were stored were p2107, b1342, v0300 and p0120. He thought there could be a problem with the PCM, but cleared the codes and told me to drive it to see if the codes come back. They also checked the wiring but could not find any areas of chafed or...
  10. J

    P2107, P0607

    Well, I spoke too soon.... 7 months later and the vehicle shut down on the interstate this morning and threw a CEL. Had it read and it was the darn P2107 code again. This time I’m having a mechanic diagnose the problem. I find it hard to believe that the throttle body or TPS would be at fault on...
  11. J

    Heater control valve

    @DILLARD.... I hadn't come across the all metal version and am wondering if that was for previous years. Since I have replaced it with a new Motorcraft version, all is well. And no more leaks with the screw clamps.
  12. J

    Heater control valve

    I went for a routine oil change this past weekend and my mechanic said they added about a gallon of coolant to the overflow reservoir as it was empty and there may be a leak. I thought that was strange as I had just checked it about a week before and it was near the full hot mark like it usually...
  13. J

    Mercury Mountaineer coolant leak problem !!!

    Hmmm, is this the pipe? 2006-2010 Ford HVAC Heater Hose 9L2Z-18696-D | GetOEMParts.com
  14. J

    Thumping sound when rear A/C is running

    Sorry. I meant rear AC, not axle!
  15. J

    Thumping sound when rear A/C is running

    Sounds like one of the blend door actuators has stripped the teeth on the internal plastic gears. Mine does the same thing periodically when I turn on the rear axle and I just haven’t gotten around to replacing it yet. You have to remove most of the trim panel in the back to replace it in the...
  16. J

    Slight shake after extensive tune up

    Just a thought. If you disconnected the battery for any length of time when you did the tune up, the PCM probably reset itself to factory specs and your vehicle may just need to relearn them over time.
  17. J

    Loud thump after starting?!?

    Probably would be easiest to have someone else start the vehicle while you listen for the noise with the hood open. Should be able to see if anything looks out of the ordinary.
  18. J

    07 Eddie Bauer 4.0 HELPPPP

    Did you use oem parts or aftermarket?
  19. J

    07 Eddie Bauer 4.0 HELPPPP

    Oh I saw you replaced the TPS already. I missed that. I’d recheck the wiring then. You may have to peel back some of the outer covering on the throttle body wiring to make sure the insulation isn’t damaged further back
  20. J

    Anyone got a part name or number for this hose

    Yeah they do with a bit of force needed. I couldn’t get the connectors to seat all the way into the ends of the hose, but it was very snug anyways and wasn’t needed.
  21. J

    07 Eddie Bauer 4.0 HELPPPP

    I’d check the wires going to the throttle position sensor (tps) on the throttle body, as well as those to the maf sensor. If they are good, you may have a bad tps. Mine was faulty and a new one fixed my issue.
  22. J

    Anyone got a part name or number for this hose

    I think this is the hose you are looking for: https://parts.ford.com/shop/en/us/fuel-system/fuel-chassis/tube-assy-fuel-vapour-separator-6523403-1#partMatched. But it is $46. I actually did what beachcomber said to do and went to Advance Auto today and got 36” worth of hose for $6.63 including...
  23. J

    P2107, P0607

    Yeah it was. The issue never came back.. knock on wood.
  24. J

    wrench light at 5500 rpm

    Check the wiring too around the Throttle body and MAF sensor. Brittle wiring that may have gotten disturbed can cause all sorts of issues. I had a similar issue that ended up being the throttle position sensor.
  25. J

    In search of a new vechile.

    4th generation Explorers/Mountaineers are old vehicles now..10+ years. A vehicle this old will likely need something down the line work wise (if not right away) upon purchase. I do preventative maintenance to the extent possible when I buy a new to me vehicle, which isn't cheap if you are having...
Top