Search results | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! Once registered you can join the Elite Explorers to eliminate ads from the website.

Search results

  1. S

    AWD Lock Mountaineer

    I never found it and determined that the option was removed for the 2008 models.
  2. S

    Clunk when letting off the accelerator

    Yes, the 3.5 EB is the only choice. I also wish they had a NA engine available. It drives really well, feels a lot smaller than it is. That is until you go to park it. We got a Limited with the 22" wheels and the CCD suspension. It's surprisingly smooth given the size of the wheels. So...
  3. S

    Clunk when letting off the accelerator

    Just to close out this thread, the insurance ended up totalling the truck. The spare was so jammed in they had to pry the tire out from the under body. However, even after removing the spare something in the drive train was still clunking. If it didn't clunk I was going to buy the truck from...
  4. S

    Clunk when letting off the accelerator

    I jacked up the truck and all bushings, mounts and universal joints look ok. At this point I'm guessing it's due to the spare tire being jammed into the rear suspension. I'd move it, but want to make sure insurance sees it incase that isn't the problem. I want them to see that everything...
  5. S

    Clunk when letting off the accelerator

    I didn't get a chance to jack up the truck, but shimmied under the back to investigate the damage more. It looks like the spare tire has been jammed into the rear suspension. I'm not sure if it's bent but everything is definitely shifted forward. The other driver had a Honda Accord and it...
  6. S

    Clunk when letting off the accelerator

    Our 2008 Mountaineer was rear ended pretty hard last night. Hard enough the truck was pushed into the vehicle in front of us. As soon as we drove away from the scene I felt and heard a fairly loud clunk when letting off of the accelerator. I can feel it in the steering wheel and floor...
  7. S

    P0740 and P2762

    Just to follow up on this issue, a new mechatronic unit fixed this issue. I ended up ordering one from eBay for $300 and had the transmission shop install and reprogram the unit. The car drives perfectly fine, and no more codes at this point. Luckily, there was no damage to the transmission...
  8. S

    P0740 and P2762

    Explorer_PL, thanks for the info. I requested the shop wait until I get the part on eBay. 1600 vs 300 I can go through 5 bad eBay ones. Even worse, after calling my Ford dealer I found out what you buy from Ford is remanufactured anyway. I'd bet Ford doesn't actually do the work, and...
  9. S

    P0740 and P2762

    I had all sorts of strange throttle body control issues a while back when I had the yellow Accel coils. I ended up removing the Accel coils and putting back the original Motorcraft black coils with new springs and insulators. I haven't had the throttle body control issues since. However, I'm...
  10. S

    P0740 and P2762

    I took the truck to an independent transmission shop. They said the mechatronic unit is bad. $2,100 to replace the unit ~$1,600 is the part alone (valve body with mechatronic). I asked about using an eBay remanufactured one since they're $300. He said he's had terrible luck with them and...
  11. S

    P0740 and P2762

    I have the 6R60 transmission. I didn't fully service it when I replaced the radiator. When I pulled the radiator I dumped all the fluid in the radiator and let the trans lines drip into an empty container. I put a little bit more new Mercon SP fluid than what I collected from the container...
  12. S

    P0740 and P2762

    Any chance anyone has the pin out for the transmission to ECM/PCM wire harness? I traced as much of the cable as I could and didn't find any breaks or rubs in the wire itself. I want to ohm out each wire but can't find where the wires connect to the computer. There are so many wires and close...
  13. S

    P0740 and P2762

    I tried to reset the codes, P0740 comes back immediately. I don't even need to start the vehicle for the code to come back. This points to something electrical. I ohmed out the transmission fuse and it was fine. P2762 will sometimes come back immediately as well. I checked the connection...
  14. S

    P0740 and P2762

    My 08 Moutaineer with 140K miles all of a sudden got real sluggish when I tried to accelerate from a stop light. The check engine and wrench light came on. Before this the truck drove perfectly fine, no indication there was any transmission issues. I checked the codes, P0740 (torque converter...
  15. S

    B1342 and C1285

    I'm randomly getting service RSC now, the traction control and ABS light. Along with alert tone that comes with it. If I shut off the truck and restart it sometimes it won't come back for a couple hundred miles, other times it'll come back right away. The truck continues to drive like...
  16. S

    Cam Phaser or Timing Chain Tensioner

    Total cost was $2,122.38. The shop had to replace all the guides both tensioners and the chains. They also had to drop the oil pan and clean it out since there were chunks of timing chain down in the pan. It was quite a bit of work and took them 3 days to complete. Some of the delay was due...
  17. S

    P2135 after TPS replacement

    I've shielded all the wires around the COPs. I'm still getting the random P2135. Today the truck just shut off immediately after starting. 2135 was pending. So all I've replaced/tried: COPs - OEM Suppression capacitors Gas pedal Throttle body (complete unit) Shielded harness wires Moved...
  18. S

    P2135 after TPS replacement

    Thanks for the information! That link was really helpful. I just got to 740 miles and the wrench came back on again. This is the furthest I've gone in a while without the wrench showing up in a while. So going back to the OEM COPs seemed to help. The last two times the wrench appeared was...
  19. S

    P2135 after TPS replacement

    Thanks for the information. Any chance you can send or post the harness test procedure? I'd like to test it myself and see if it truly is the harness. If so, I'll probably break down and put a new one in. Thanks.
  20. S

    P2135 after TPS replacement

    I replaced the throttle body with a brand new Ford throttle body, bought from a dealer. After 600 miles the truck went into limp home mode again, orange wrench with check engine light. Since the truck didn't shut off I brought the truck to the dealer with the check engine light on. P2135 was...
  21. S

    P2135 after TPS replacement

    I've finally had a chance to bring the truck to the dealer. Of course the truck isn't currently acting up so they can't find anything wrong. Nothing is stored in the computer and they say it drives fine. At this point I may try another throttle body. If that doesn't work maybe it's the...
  22. S

    P2135 after TPS replacement

    Since the TPS didn't fix the problem, I completely replaced the entire throttle body with a remanufactured CARDONE one. After about 500 miles the truck started shuttering and threw the wrench again. P2135 again... I'm really at a loss as to what the problem could be. I checked the TPS cable...
  23. S

    2008 Explorer A/C blowing warm from Drivers side Vents

    Had the same problem. Like Big Z said, I was low on refrigerant. Added some and both sides are the same temperature now.
  24. S

    P2135 after TPS replacement

    I investigated the throttle body more and see the butterfly is snapping shut when I get very close to almost having my foot off the gas pedal. Seems like motor and throttle position sensor is out of sync. I tried disconnecting the battery to reset the idle position, but that didn't make a...
  25. S

    P2135 after TPS replacement

    So when it rains it pours. Just did all the timing on my truck and now the truck decided to turn off while driving. I got the wrench a few days ago so I pulled the codes and got P2135. I replaced the TPS thinking that should fix the problem. Today the truck stopped accelerating and shut off...
Top