dead | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

dead

  1. N

    92' Explorer - Installed new BT deck - Won't start now

    I installed a new deck and now my Explorer won't start - I was able to use a jump box to start it .. That lasted about 5 or 7 days .. Now it won't even start with a jump from another vehicle. New battery and terminals .. So I'm stumped. I'm about to give the starter a wack or two. When it's...
  2. M

    Battery...........

    So, the other day when I went and grabbed some to-go Chinese Buffet, I came out and my 92 Explorer wouldn't start. Awesome. Didn't leave anything on that I saw, but I had left the windshield wiper switch turned on to like... medium speed. However, when the car is off, the windshield wipers...
  3. M

    Frustrating: NEW problem

    My 1992 Ford Explorer XLT 4.0 4wd has been non-stop frustration, and today there is an entirely new problem: NO ELECTRICAL. The battery is new and charged, but there is no electrical whatsoever: no dim lights, no clicking starter, nothing. What might be a logical problem (such as a main...
  4. J

    92 explorer wont start

    Help! So i got in my car today and it started fine, went to drive down the road and it drove (barely shifting as usual). I forgot to close the rear window so i pulled over shut it then tried to start it and it wouldnt crank. Im in the process of doing a auto to manual swap and this morning i...
  5. E

    dead battery all the time...

    okay so i charged my battery yesterday fully and now today went to start it and battery is completly dead how can i find out whats pulling juice to fix it?
  6. L

    Electrical problem - Fuse 8 in Power Dist. Box blows - How do I find the fault?

    :exp: My ride: 1992 Explorer 4.0L V6 pushrod with AC and 4WD My engine shut off while I was driving, about two miles from home where I had left. It died without warning or sputtering, radio and lights still working. I tried to start it again, and the engine turned over but would not start...
  7. G

    Think I may have a issue with the computer..

    So this is a issue I'm having. For some reason, sometimes my explorer won't start. Its not the starter, we've had it tested along w/ the solenoid, changed the battery and relays. Most of the time it starts fine, no problem, but if we've been driving for awhile and the engine is hot,or its hot...
  8. T

    Everything went dead when the key was turned.

    Just bought a 95 Ford Aeostar XLT conversion van. It had been starting fine, but went out today & opened the door. The door chime sounded as usual, but the moment that I turned the key to start it, everything went dead. There was no click, no anything. Now the door chime will not even...
  9. S

    battery problems WTF!

    ok, so i have had this truck about 3 months now, and so far the alternator has gone (within 1 week), now i had to replace the battery because the battery was leaking acid. did that yesterday, started up fine. this morning i go out to start the damn thing and kaput. F*** so that makes 2 days in a...
  10. C

    Worst day of my life, goodbye ex.

    I cant believe this happened to me i had a 94 explorer till this morning, i was 4wheelin with broken 4 wheel drive in soft dirt like an idiot and my left wheel dropped in a crevice between two rocks trying to get out i dug a whole for my back right wheel (only one turning) and my friend couldnt...
  11. A

    Car wont start... clicking

    Drove home yesterday parked in front of my house went to get into my car ry to start it it started turning over and died. then ... CLick and kept clicking every time I tried it. Terminals were a little corroded so I went bought new ones. Click. Went to bed woke up this mroning...
  12. J

    Need Help! battery light came on 2 days ago and my truck just turned off while drivin

    Help! The battery light on my 94 ranger came on 2 days ago and last night it just turned off while I was driving. I couldn't even get the hazards to turn on. It has no power at all.I've heard it could be the cables corroding on the inside. There is no outer corrosion. Any suggestions would be...
  13. D

    Hating my explorer

    Bought an explorer this january used. its a 1993 eddie bauer edition. it ran great for awhile. unfortunately ran into a buttload of problems. First was losing heat during a bad blizzard season. replacing the heater core (of course after changing the coolant and having the water pump removed and...
  14. C

    No Fuel Problem - Help diagnosing the issue at hand?

    Ok... So first to explain a funny, but extremely IRRITATING story... The long and short of it is, I sold my explorer told (or so I thought...). It has always ran well, guy came and looked at it, took it for a test-drive and all was well. We agreed on a price, he went and got money, came back...
Top