• Register Today It's free! This box and some ads will disappear once registered!

^^Searches ExplorerForum.com^^

electrical

  1. D

    Electrical? Transmission? Help!

    I'm hoping someone can help me. I have an 03 ex 4.0 I've had for a little over a year. It sat for 2 years because of a gas leak they couldn't or didn't want to fix. We put a battery on it and drove it home with no problem except gas leak and door ajar light on. And a new fuel pump fixed the gas...
  2. J

    1996 Explorer sun roof

    Hello all, I have a 1996 Explorer Ltd. Today, for the first time, the sun roof would operate to open but would not close. I removed the upper console (all other functions were normal) and looked for any obvious signs of failure with the switch, then manually closed to roof. Finding no signs of a...
  3. J

    Multiple issues looking for help 95 xlt

    I'm looking for some help with a 95' ford explorer. Having a lot of issues with it right now and I'm trying to figure out the cheapest way to resolve it. Any help would be appreciated I know some basics when it comes to vehicles but I do not have any in-depth knowledge. Trying to put as little...
  4. E

    91 explorer dies intermittently

    Still can’t figure out my 91 explorer. It will idle about 5 minutes then die. I can go drive it and it dies intermittently then fires right back up on side of road. It has codes 87 and 95. I did hook a fuel pressure gauge to it and it does not lose fuel pressure when it dies. Things I have...
  5. W

    Electrical madness

    So I got a 93 explorer xlt not too long ago. I was driving up at high elevation and the car just decelerated for a second and died on an uphill. After getting it home and inspecting further I noticed that none of the infotainment center was lighting up and the ignition wasn’t clicking at all...
  6. K

    Steering wheel buttons

    I recently totaled my 2013 Explorer XLT, no complaints. Purchased a 2018 with 28,000 miles, with equipment group 202A and the safe and smart package. Anyways, on occassion the cruise control will stop working while staying on and will not re-engage when prompted. Even turning it off then back...
  7. E

    '02 Wierd grimlin between clutch and instrument panel

    Rebuilding an abused 2002, manual 4wd V6, so I give it more sentimental value than bluebook. I replaced the entire wire harness in the dash which had been hacked and spliced ad nauseam, replaced the PCM which cleared a few other engine faults, and swapped a few GEMs salvaged from the junk yard...
  8. S

    Electrical issues with interior/courtesy lighting

    Hello all! My 04 explorer has been having a strange issue that, thus far, I have heard of no one else having anywhere, from this forum to other websites. My interior lights are no longer turning on when any door is opened or when the light dial is turned all the way up. All interior lights still...
  9. S

    Hello and a question.

    Hello! Ive been a frequent lurker of old threads sifting through different guides and fixes for various problems. Ive finally decided to make an account so that I have more accessability and options on this platform. However, my 04 explorer has been having a strange issue that, thus far, I have...
  10. A

    2008 Explorer - Car starts, drives but then won't start later but then starts again magically

    I'm hoping you can help me since I'm not finding anything with my google searching or even a way to best say the problem. Car: 2008 Explorer XLT 4x4 with about 135K miles. Major work: rebuilt transmission in Jan 2020 Minor work: new interstate battery April 2020 TL;DR problem: Car has begun a...
  11. M

    95 Explorer Starting Issues

    I have a 95 XLT Explorer with 193,600 miles. Everyday, I will have one to two bad startups, where the engine goes below 500 rpm then will stall out if I don’t put my foot on the gas and bring it up to about 2000 rpm where a small rattling sound can be heard which subsides. After that it will...
  12. ibstang

    Parking (Running) Lts Failure...

    I haven't spent much time with new-kid intro's (pardon me), but I've been having an incredible experience wandering the vast halls of Explorer lore at hand... I've recently acquired an '05 Explorer XLT, at what I thought (at the time) was a bargain price. HMMM... The issue at...
  13. A

    SOS No Crank No Start

    I am brand new to this forum, thank you for accepting me to this forum. This is my first post! I have a 2008 Ford Explorer XLT, 4.0 V6, 4WD. It has 130,000 miles. Here is the list of electrical symptoms I have had recently - starting a month ago it took a few more cranks than usual to start up...
  14. J

    Camshaft Position Sensor/Electrical Problems

    As stated in a previous post, I have multiple codes on my 2003 Ford Explorer Centennial Edition, 4.6L. After testing my alternator I figured most of them were due to it being weak. After removing countless alternators at the junkyard and testing them outside of the vehicle, I finally found one...
  15. D

    Buzzing noise under dash when car is off

    I have a 2017 Explorer and just had the dealer put a new battery in. After opening and closing and leaving some doors open over the weekend while camping and also having the aux on to charge my phone (something I do all the time) my battery was dead, and I mean really dead, had to charge it for...
  16. L

    Right Side Headlights stopped working

    Hi Gang, I checked the bulb (replaced it) and checked the fuse. all seem to be working. My Explorer is a 2006 XLT and it's stock as far as I can tell. At least nothing externally appears to be modified except for a aftermarket radio. What else can I check? I plan to check the plug...
  17. T

    08 Explorer XLT 4x4 No Turn Signals, relay clicking

    hello everyone. I’m working on a friends explorer and I am having difficulty diagnosing a no turn signal problem. We have running lights, but no turn signals lights, and no low mount brake lights. The top mount brake light works. All bulbs are brand new. And the indicator lights on the...
  18. E

    It's like the battery isn't connected....

    I have a 1997 Explorer with the 4.0 SOHC. I have recently had the timing chains replaced and has been running fine now for a couple of weeks. A couple of days ago, about 10 degrees out. Upon attempting to start the vehicle, I would here nothing but a loud click. I attempted to start it too many...
  19. T

    Strange and Mysterious Electrical Issues

    Hello All, My 2002 Ford Explorer XLT 4.0L V6 is having the weirdest electrical issue. To preface, my mom bought this car in 2001 and she loved it. I recently bought it and promised to take to 200k. It has 199,981 miles. I want those last 19 miles so bad it hurts. Here's what's going on: This...
  20. J

    Mystery Connector - found searching for bouncing voltage issue.

    Been fighting with the bouncing voltage issue on my stock '94 Navajo. Replaced voltage regulator and brushes on existing alternator, then replaced whole alternator with a new one and initially thought resolved, but the issue returned. Looked for loose/bad connections and couldn't find anything...
  21. 0

    Water causing car to not start?

    I have a 2000 Ford explorer sport. It has been raining and I drove through a large puddle and shortly after while sitting at an intersection it quit running. It would not start back up, when I try to start it the engine will turn over it just wont start. I have had issues with the starter before...
  22. C

    Explorer doesn't crank

    My sister drove her car to work parked it and turned it off, hours later after work she got back into her car went to start it up, the lights worked, the radio works, the engine didn't turn over, replaced the starter and starter solenoid (both 1 piece) with new parts, still didn't turn over...
  23. D

    Electrical is gone...

    Hi all.. I'm a newbie, so I'm hope this is appropriate. I searched for a specific thread on this topic but didn't see one. I've not tried the general troubleshooting tip about inspecting the two big "bundles" of wires, but I will. In the meantime, in case anyone has suggestions: i've got a 97...
  24. 0

    Radio keeps shutting off every 50 seconds

    I have a 2000 ford explorer 2wd, when I got it, it had a number of electrical issues, but I'm stumped on this one. I replaced the connector that goes into the stock radio because it was damaged and no longer fit, I noticed that the people before me had already swapped them out. When I connected...
  25. M

    Parking lights stay on

    Hi, 2006 Explorer Limited 7 passengers 4x4 4.6L, Stock. A few nights ago, I forgot my sunroof open. And it rained. In the morning, the parking lights where lit. Now, the only way to turn them off is to take out the fuse in the underhood fusebox. Everything else works fine. What do you think...
Top