fuel | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

  • Holiday Special! - 2 for 1 Elite Explorer sale!

    Right now you can purchase an Elite Explorer membership for $20 and receive a two year membership! If you have an existing Elite membership contact me by PM and I will upgrade your account manually.

    Click Here to start your membership and get rid of the ads!

fuel

  1. K

    Fuel pressure rise after engine shutoff

    Car struggling to start and when Engine runs it seems fine with little vibration at 25 psi of fuel Rail Pressure. If I shutoff the engine, it drops immediately to 8-11 psi and gradually rises to 42 psi. I try to start the engine again FRP drops and engine stalls it won’t start until I wait for...
  2. JSWarrell

    How to: Fuel Vapor Line Repair (EVAP)

    So this is more of a "How I did it" rather than a How-to, but I decided to fully document my repair as I found no info on this before. I don't know how helpful this will be for 91-92 owners, but I'm guessing the only real difference in the systems is that the vapor canister is in a slightly...
  3. M

    fuel rail removal in reinstall help 2005 4.6

    How do I remove the fuel rail? Currently replacing the intake manifold and am puzzled by how to remove it on both sides.
  4. 2

    Fuel Pump Dead

    I replaced my fuel filter today so I used the method were you pull the relay to the pump while it’s running to remove pressure from the lines. That definitely worked as I changed the filter and the lines were depressurized. But now my pump isn’t turning on, I don’t hear the usual whirl sound and...
  5. B

    My Gas Gauge is WONKY!

    Hello, I recently purchased a 2016 explorer sport with the 3.5L twin turbo and my fuel gauge seems to go up to full when i go into higher elevation and when driving it went from 150 miles to empty to 0 damn near instantly. Upon putting in gas I did infact have 2 gallons of fuel left in the...
  6. T

    Ground wire fpdm 04 explorer xlt 2wd

    Hi guys! I need help. My ground wire is bad on my fuel pump. Im trying to figure out where the ground wire leads to on the fpdm. I know the location of the fpdm i dont know where the ground leads and i cant find anything on it. Thank you in advance!
  7. T

    Is there help to Replace Fuel Injector 4.6L

    Hello, I'm struggling to find any write ups on how to replace a cracked fuel injector I have on my 2008 Explorer 4.6L. Everything I find is for the 4.0L. Can anyone lead me in the right direction. Thanks in advance.
  8. H

    Slow fuel fill

    My 2006 eb 4.6l won't take any gas and I'm assuming it's cause of that vent hose that runs up to the top of the filler neck. Ive read on a few forums here that ford made a redesigned vent hose, I'm just wondering where would I find that. Or if it would just be better to take it to a mechanic and...
  9. D

    Hard to start 99 4.0 sohc

    got this 4.0 1999 explorer it turns over way too much before it cranks . I have cleaned the mas sensor , cleaned the whole intake system with sea foam , I have replaced a bad iac valve with a new one . There are no vacuumed leaks . I bought it not long ago and noticed the temp guage wasn’t going...
  10. G

    2006 Explorer 4.0 6 cylinder won’t start - fuel

    The truck ran fine then one day just quit, wouldn’t start again. I have shot starter fluid into the air intake, it runs for a few revs. I have replaced the fuel pump, filter. Any ideas, next steps?
  11. C

    lack of power - fuel pump going bad?

    I am stumped. I have an 05 explorer xlt, 4.0 SOHC V6 with 191K miles. With about 8K in repairs In the past 6 months I have replaced, the front wheel hub assemblies, rear tie rods, upper and lower ball joints, TRANSMISSION, replaced the fuel filter, oil change/air filter, had the throttle body...
  12. S

    Hard starts, extended cranking time, fuel smell

    Hi all, I'm new here and have been having major issues with my 2013 explorer limited, 3.5 awd. Bought it 2014 with 52k ran great. At 60k I had the great idea to put in E85(yes it is flex fuel) I was almost empty when I did. First tank, CEL came on was told it was normal from dealership...
  13. M

    Check Gauge Light after Refueling

    This is on a 2003 Explorer XLT AWD 4.0L Whenever refueling the tank when near to empty (under 1/4 tank), the gauge will sit right where it was, even if filling the tank. Then about 5-10 minutes into driving, it will drop to empty and appear as if the gauge isn't working at all, the check gauge...
  14. Y

    bank 1 and 2 lean codes fix?

    hey guys so i just picked up a 1998 ford explorer sport (2 door v6) 88k miles magically the CEL came on after 250 miles of driving (i know i should have checked to see if it was reset) codes were P0171 and P0174. -I ran some injector cleaner thru and dry gas as well, reset and light came back...
  15. 2

    Best way to relieve fuel line pressure?

    I’m going to attempt to change the fuel filter on my 2000 OHV and was wondering how to depressurize the fuel line. I’ve read that unplugging the inertia switch and then cranking the engine until the fuel runs out, is the best way. I’ve also read that removing the fuel pump fuse and then cranking...
  16. M

    Quit running and won't start

    Hi Guys... Wife was driving the 2001 Sport Trac and it started to lose power, then stopped running. I checked it out and when I try and start it, it produces a rythmic clicking sound. Checked the battery and terminals and it appears the car is getting sufficient power... never did this before...
  17. W

    CEL with code P0102 and already replaced MAF. Please help

    My 99 explorer 5.0 has CEL P0102 low voltage MAF sensor. I have replaced the sensor, the connector, throttle body sensor, IAC valve, gaskets and checked for vacumm leak although there seems to be a leak i can't find after the MAF sensor. What else can be causing this code? I can't get it smogged...
  18. R

    Fuel filter lines for a 2002 and other problems.

    I decided to jump into replacing the fuel pump on my friend's dad's 2002 Explorer b/c he is tight on cash. It's turned into a bear of a job. My first problem is getting the two fuel lines going into fuel filter off. They do not use the quick disconnect tool that the out-going fuel line uses, and...
  19. J

    Vehicle always stars but putters

    Hello, I own a 2013 Ford Explorer XLT Flex Fuel and I am having a problem when I start the vehicle. It always starts, however, it does not start like when it was new. It sometimes starts right away but sometimes it will putter for about two to three seconds and then it starts. Usually it...
  20. C

    2008 Ford Explorer 4.0 running problem

    Hi. I have a 2008 Ford Explorer that just recently started to stall on me while driving. I replaced the fuel rail pressure sensor, fuel pump, fuel pump module, cleaned the maf sensor, throttle body with tps and idle control. When in park it runs great but once you put it in gear the fuel...
  21. 2

    Rattling when accelerating

    this morning my truck made this rattle noise when I accelerate. It does it when i'm in park and I rev it to a certain point as well. I tried to do some research on it. And I saw something about switching gas. I originally always used the normal 87. Then someone told me to use 89. They said it...
  22. R

    '05 XLT Intermittent No start. Cranks, has fuel, has spark. is it posessed?

    2005 Ford Explorer XLT. 4.0 V6 198,000mi Every so often my explorer has a strange running issue. 2/3 of the time i experience this issue It starts, then dies within 5-30 seconds. (usually when reversing out of my driveway) the other 1/3 it won't start at all but has the same symptoms as after...
  23. bronchole

    2005 Mounty 4.0 persistant P0193 code

    The car: 2005 2WD 4.0 automatic with about 110K miles on it. The symptoms: Check Engine light comes back on within 20-40 miles of being reset P0193 code (fuel pressure sensor high) Poor gas millage, around 12 MPG (was about 18 MPG a year ago) Occasionally runs slightly rough, mainly at idle We...
  24. J

    Help with a starting/running issue!

    Hello, I just finished replacing my heads and manifolds with headers. Got it all back together went to start it and it started right up. Wouldnt idle but thats nothing new (Probably bad IAC). Normally it will idle after a minute or so of holding the gas to about 1K rms. It did eventually idle...
  25. T

    2000 Ford Explorer's not getting fuel. Losing my mind!

    Hey guys, first off... I'm not stranger to these forums, but the only difference now is, I'm now a member. I've been directing friends here for a while that own Fords, and I personally, always wanted to own one and now I do. I'm no mechanic by far, I'm just learning, and I must say...even...
Top