high idle | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

high idle

  1. E

    Codes 87 and 95 dies intermittently with high idle

    Hello, I have a 91 Ford Explorer 4.0. Vehicle sat for a year and leaked water down to the computer. Replaced computer and then ran good. However, it only makes it about 15 miles then CEL comes on, loses power, idle ramps up to about 2 thousand RPM on side of road and dies once I give it some...
  2. A

    Solved High Idle - 91 Explorer Eddie Bauer

    Is there anyone out there that can help me with a high idle problem? The issue i am having is the engine kicks from normal idle (800ish rpms) to a very high idle (1800 rpms) for no reason. I know on some cars you can hear it click and it idles up a little bit but nowhere near like this...
  3. mfitz725

    High idleidentity problem

    I made the mistake of disconnecting the battery to change the alternator, now the engine doesn't want to relearn idle. It runs consistently at 2000 rpm. I have tried disconnecting the battery again to no avail. Was wondering if the idle air control valve IAC could be a problem or if any has any...
  4. G

    changed iac valve, now revs to 3k rpm on start up

    i just changed my IAC valve on my 2002 4.6, i changed it because of rough idle. when i took the old one off it was missing the spring. but now it idles fine and runs smooth. but on startup it revs to almost 3k rpm for about 5 seconds then drops to normal idle rpm. is this normal? kinda freaked...
  5. A

    91 Explorer - Trans Won't Shift

    The other morning I was driving home and went to pass someone, gently pushed the pedal down to get it to kick into passing gear and it did. About 2 seconds later it sounded like it completely slipped out of gears and the RPM's skyrocketed. I immediately let off the gas as soon as i realized...
  6. K

    Need help with strange idle problems on my 94 Explorer

    I have a 94 Explorer with 4.0 ohv non egr 5 speed standard I rebuilt a year ago. Every sensor is bran new. A month ago I started experiencing difficult starts and high idles. When the truck is cold I can start it and it will take at least 45 seconds of the engine trying to stall before it...
  7. M

    2002 Explorer idles high when slowing down

    Hey, I have a 2002 Explorer 4.6L and I recently changed the IAC valve because when the car was cold it would not stay on. Changing the IAC did fix the issue of it not staying on when it was cold but now I find it pulls hard as I slow down to stop and once I am about to stop the rpm's drop and it...
  8. N

    High Idle

    Hello all. First off Im a Diesel Tech but I just got a 2009 Ford Explorer that has a high Idle and throws a code. If you clear the code it idles just fine for a few days. So we threw a few parts at it. New throttle body, IAC, TPS and a new MAF. Still the same problem. While veiwing data stream...
  9. K

    91 explorer body and transmission/ 94 engine

    I got a used 94 explorer engine for my 91 explorer. The engine was incomplete, because the intake manifold didnt come with it; so i put my old 91 intake manifold on the 94 engine. Everithing bolted on right. Plugged up all electrical, but i didnt lable the vacuum hoses to where they go and join...
  10. J

    High Idle and Shifting is Off

    2003 Ex with the 4.6L and 143k miles. At a warm or cold start up, the RPMs jump to 2k then very slowly drop to around 900-1k. While driving, the RPMs stay higher than normal when the trans is shifting. It seems like the RPMs are 300-500 RPMs higher than normal. There have been times where...
  11. T

    Intermittent High Idle at start 98 sohc

    i have an issue when i start my explorer. about 1 out of every 6-7 starts my car will go from the normal 1200 or so rpm up to 2500 rpm. its 70 degrees at night right now so its not a being cold issue. about the same time i noticed that my mileage dropped a bit, not a ton, but about 30 or miles...
  12. A

    my new Exploder

    :) it is so called affectionatly, so please no one get mad, lol, i am Chevy girl normally after all, but i do love my new Explorer. Its a 94 2 door sport 4x4. im trying to figure a few things out, (dont know much but i love learning and fixing my own stuff so bear with me if some of this...
  13. drakeguy22

    rough idle, stalling engine please help

    okay here is the low down... i had 2 plug wires melt on my valve cover while traveling on the thruway.... obviously caused some problems.... fixed that(new plugs and wires) but now it will not idle for the life of it when its warm.... its standard, 4.0 OHV. i have no clue whats up.... i checked...
Top