• Register Today It's free! This box and some ads will disappear once registered!

^^Searches ExplorerForum.com^^

rough idle

  1. R

    Vacuum line leaking transmission fluid on tree

    Hey everyone hope all is well I have another question ik for a fact that I have a vacuum leak somewhere on my 1993 Ford Explorer XLT 4x4 I've replaced the IAC valve and purge valve I can hear air escaping when I turn the truck off and it sometimes doesn't wanna start up it idles rough and it...
  2. T

    At my wits end with this issue

    Hi all, I've been trying to use this ex as a learning experience for myself, as well as to eventually use as my daily driver. Obviously, for that to be the case, it needs to be running perfectly, and i shouldn't have to worry about it being a danger to myself or others. However, with this...
  3. C

    2007 Ford Explorer 100$ bounty

    Took it to ford and paid 1000$ to have nothing fixed and for it to come back with an oil and coolant leak that’s gonna cost me an additional 1000$ to repair from quotes with the initial problem still being present. I don’t have the money. Anybody willing to give me advice that actually has...
  4. P

    '05 XLT V6, P0303 & no compression -- head gasket? valve? piston?-- pls help diagnose (video)

    '05 XLT V6, ~85k. Truck was suffering from P0430 (Catalyst system efficiency below threshold (Bank 2)) and moderately uneven idle for few years, but yesterday -- peaceful local driving, stopped at intersection, when started moving (no noticeable "pop" or "clang" or whatever) -- engine shaking...
  5. J

    2008 Explorer Sport Trac 4.0 V6 Stalling/rough Idle issue Mystery, Experts help needed please!

    Hey guys, so my father in law has been having bad luck recently where his truck is symptomatic of the notorious rough idle/stalling issues. Being that it is such a typical event he took it to an indy shop for diagnosing and fixing. At the shop they changed the intake manifold with a new one and...
  6. S

    Rolling/Surging Idle w/ AC On (TSB 15-0149)

    I think I understand the issue related to TSB 15-0149. See video below for my thoughts. Here was a video I made before (Oct 2015) showing the issue but the dealer just said it was a little low on Freon, still seemed to have the issue and then I found the TSB (of course after the warranty...
  7. S

    1997 4.0L V6 OHV Shakes my whole suv

    When i am driving and i come to a stop my Explorer shakes super hard, it's idling rough. I don't know why, anybody have any ideas. I like to fix everything myself and i have big plans for this car. If i can get it to run nicely im gonna keep the original engine. I was thinking about swapping the...
  8. S

    Frustrated with rough idle when warm in drive

    Hi all, I have a 2000 Explorer 4.0L V-6 OHV (X) with the CE light on and codes P0306, P0171, P0174. It starts great runs good but has a rough idle stumbling when warm waiting at a light. It has 198K miles on her but the engine has less than 30K. I've done a lot of work on this truck in the past...
  9. E

    Changed Plugs In my 05 explorer XLT 4.0L now it idles rough at low rpm idle.

    So to start off Im new to working on Ford vehicles. Recently purchased this explorer, it ran well, but its got some miles on it so I decided to give it a once over and do some preventative maintenance. Air filter, oil change, the muffler had a hole in it so i put a new one on, and fixed the...
  10. W

    CEL with code P0102 and already replaced MAF. Please help

    My 99 explorer 5.0 has CEL P0102 low voltage MAF sensor. I have replaced the sensor, the connector, throttle body sensor, IAC valve, gaskets and checked for vacumm leak although there seems to be a leak i can't find after the MAF sensor. What else can be causing this code? I can't get it smogged...
  11. Z

    Rough Idle, Clicking Noise, and Decreased MPG

    About 2 months ago I pulled my Explorer out of storage where it has been for the past 3 years while I was in Germany. I flushed all of the fluids and got a new battery, family borrowed mine and lost it. First couple of weeks it ran fine but intermittently it wouldnt start, checked it off to...
  12. F

    06 Explorer Rough Idle when in Park..Help

    Here is what I got: 2006 Eddie Bauer 4x4 4.0 Sohc v6 121,000 Miles Here is what happened: Vehicle overheated due to thermostat housing melted and seam separated. Here is what I've done: Replaced Thermostat housing Radiator Flush and fluid replace Oil Flush and fluid replace Changed PCM,spark...
  13. J

    Trying to track down lean codes (P0171, P0174)

    I have been getting the lean codes for Bank 1 and Bank 2. I clean and replaced MAF. I had previously replaced the famous vacuum elbow (and it's still good). I have had a smoke test done to find any other vacuum leaks. A small amount of smoke came from the EGR, replaced it. The codes have...
  14. F

    Is it really the intake manifold gaskets?

    Okay, first let me say that I am an Expedition man. I love my Expy. What brings me here is my significant others 1998 Ford Explorer EB 4x4. I guess the only engine put in those was the 4.0 at the time? Anyway, one day she went out to crank it and it would not start. A friend changed the...
  15. C

    Rough idle at startup

    Hello, my name is Chris and although I have came here for help with my Explorer for years, I just joined today. Thanks for all the help I've received in the past and will receive in the future. The problem I'm having is rough idle at cold and warm startup. It clears up and runs smooth in less...
  16. Z

    93 Explorer shuts off on its own after warming up.

    It starts up and runs like a champ. But after about 3-5 mins of it running. It starts running really rough and will eventually shut off all on its own. It smells really bad because of it running so rich. Ive already cleaned the snot out of the MAF sensor, knocked out both catalytic converters...
  17. A

    Rough running after tune-up 5.0 v8

    Greetings fellow enthusiasts (and sufferers)! I recently purchased a 01 (98-01) Explorer Eddie Bauer with the seemingly rare gem of a 5.0 V8. She's a beauty and couldn't be happier even with the 198k miles! However. I was in line getting pizza and the dreaded check engine light came on. She...
  18. G

    03 Explorer Running REALLY roug&

    Hi I am a new member and I just bought an Explorer about 2 weeks ago. I got it, it wasn't quite running well, I pulled the codes up and it was throwing a code for the camshaft position sensor. I did a tune up (spark plugs, wires, oil, all filters), changed camshaft position sensor and the car...
  19. D

    2003 Sport Trac Rough/Pulsing Idle on Startup

    My 2003 Sport Trac with 165k miles has recently started to pulse at idle on a cold start, with the pulses smoothing out with 30 seconds or so. Although the revs hold constant at ~1000rpm, it feels as if someone is pumping the gas. The problem is most pronounced if idling in gear (forward or...
  20. G

    changed iac valve, now revs to 3k rpm on start up

    i just changed my IAC valve on my 2002 4.6, i changed it because of rough idle. when i took the old one off it was missing the spring. but now it idles fine and runs smooth. but on startup it revs to almost 3k rpm for about 5 seconds then drops to normal idle rpm. is this normal? kinda freaked...
  21. J

    2013 explorer 3.5 rough idle p219a and p0303

    Stopped at a gas station and afterwards check engine light came on. Throwing code p219a and p0303. Rough idle and drinking some gas. Have had the coils and plugs and injectors checked and cleaned. Everything is running right. Changed the purge valve, still not fixed. Clear the codes and start...
  22. J

    2004 4.0L Cold start issues

    When it's below below freezing outside my explorer has trouble starting and initial rough idle. When I scan for trouble codes I get P0302 which is a misfire on cylinder 2 and a P0316 which is engine misfire detected on startup. Once it's been running for about 30 seconds to a minute the rough...
  23. P

    How do I clean the air vents/Should I replace blend door? (also rough idle/possible battery issues?)

    Okay, so this is a simple question, since my explorer is a 98 the plastic is obviously kinda old. However, the vents are hard to mess with because the close/open knobs like to stick, and moving it up/down and left/right is also hard, cause the plastic just wants to stick together so I feel like...
  24. C

    P2195 and P0108 rough Idling - Ford explorer 2006

    Dear Explorers, I have been recently facing some issues with my cars drive. On checking the codes through OBD-II reader i can see following codes coming up. P0108 - Manifold Absolute Pressure / Barometric Pressure Circuit High P2195 - O2 Sensor Signal Biased / Stuck Lean Bank 1 Sensor 1 I have...
  25. B

    HELP... 02 4.0L SOHC - Hissing noise, rough idle

    Hello all. I've just completed a valve cover gasket replacement on my 2002 4.0L SOHC 4WD Explorer, with help from several threads on here. I've gotten everything back together (after hours of messing with the EGR tube), and now I've got a rough idle and a hissing sound from the rear of the...
Top