• Register Today It's free! This box and some ads will disappear once registered!

^^Searches ExplorerForum.com^^

running rich

  1. N

    failed smog, running rich, code 14, electronic control assembly, or o2 sensor?

    So I have a 91 Explorer that just failed smog because it was running rich. about 7 years ago I had the same problem, I changed out several sensors on the truck, and the 1 that finally passed it was the O2 sensor. This time around I ran my scanner on it, KEY ON ENGINE OFF I got a code 14 the...
  2. S

    94 ranger 4.0 mass air flow output to high

    my ranger has been running to rich and blowing black smoke revs up fine but when driving cutts out replaced plugs and mass air flow sensor but my out put signal is to high on mass air flow need help.
  3. red.EDDIE.4x4

    Running a bit rich...suggestions anybody?

    ok so i have a pretty much bone stock 4.0 in my 93 x. on my most recent trip to firestone the manager took it for a test drive for final inspection. and he told me that the plugs were pretty black for only being 2 years old and that my fuel mixture was pretty rich. i know him on a personal...
  4. I

    2001 Explorer Sport 4.0 SOHC Cylinder Misfire Codes

    Hi, I'm new to this site and this vehicle as well. I purchased it with 106,000 mi., and a number of problems. I am hoping that someone can shed some light. Besides the low speed firing of the ABS system that is bugging me, I am pulling numerous codes on bank two for random misfire, cyl 4,5,6...
Top