01 5.0 CEL after fuel pump replacement | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

01 5.0 CEL after fuel pump replacement

Ford94sho

New Member
Joined
March 7, 2021
Messages
6
Reaction score
0
City, State
Oxford, NC
Year, Model & Trim Level
2001 Explorer XLT 5.0 2wd
Wanted to get some thoughts for everyone. Had the fuel pump replaced after it died, initially no issues. 5-600 miles in, started starting hard, have to cycle to key off a time or 2. CEL popped on with a P0171. Best I can find is a lean condition on bank 1, so I checked the pressure at the rail, holding 47-48 at idle. Pretty irritated after getting home and finding they stuck autozones house brand in after I made it very clear I wanted a Delphi put it at a minimum, as the oe was like 3-4 weeks out. Other than that it runs ok though. Take it back and make them yank it back out?
 
<

Join the Elite Explorers $20 Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




C420sailor

Explorer Addict
Joined
July 29, 2008
Messages
1,163
Reaction score
549
City, State
Long Island, NY
Year, Model & Trim Level
98 XLT SOHC, 99 EB 5.0L
Absolutely. This is not your problem to fix. They wanna use shit parts, they can drop your tank again.
 
<



J_C

Explorer Addict
Joined
July 30, 2009
Messages
3,855
Reaction score
714
City, State
Florence, KY
Year, Model & Trim Level
1998 XLT 4WD 4.0L SOHC
Yes have them replace it, but if they did not replace the fuel filter and it's the original or still very old or there was sediment in the tank, that's something else to look at.

What was the part # on the Autozone house brand pump? Looking at Autozone's site, they show they have the Delphi in stock at my local AZ, but they don't show any Duralast offerings which is usually what they call their house brand, only other one stocked local to me is a PFS brand.


 
<



Ford94sho

New Member
Joined
March 7, 2021
Messages
6
Reaction score
0
City, State
Oxford, NC
Year, Model & Trim Level
2001 Explorer XLT 5.0 2wd
They installed the Spectra D2296H, which the store here in NC says is their “house brand”, since they dont have the entire assembly under they Duralast brand. They did install a new filter as well.
 
<



EB4X

Well-Known Member
Joined
December 28, 2016
Messages
918
Reaction score
399
City, State
Orange county, Ca
Year, Model & Trim Level
95 Explorer 4X 4.0 ohv
So what was their response to not putting in a Delphi or better as you requested?
 
<



Ford94sho

New Member
Joined
March 7, 2021
Messages
6
Reaction score
0
City, State
Oxford, NC
Year, Model & Trim Level
2001 Explorer XLT 5.0 2wd
So what was their response to not putting in a Delphi or better as you requested?
Honestly I just started digging into all of this Sunday. Ive had to take a few days to cool off, so my temper doesn’t get the best of me in their office🤣
 
<



Top