03 5R55S shift issues | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

03 5R55S shift issues

bcbow1971

Member
Joined
June 4, 2012
Messages
25
Reaction score
0
City, State
Central KY
Year, Model & Trim Level
2003 Ford Explorer XLT4.6
OK I am thinking I may be posting what is already said, which I hope I missed it because that means someone has the same issue and cure/fix. I have an 03 XLT V8 with Tranny code V 5R55S I believe. Issue is hard shifting to second with normal acceleration and O/D light flashing. OK I noticed after warm up it shifts harder into 2nd gear and to make it shift smoother I have to accelerate easy but rest of gears shift normal. once engine/tranny warm up the OD light will come on and not shift into OD but will work if tranny isnt all the way warm or if I restart and od light goes out it wil shift in and out of OD as well with OD on/off switch.

Service engine light soon light on as well.....had it run at Autozone and had the following codes and was referred to Transmission shop for free diagnostic check.

Codes:
P0732 Gear 2 incorrect ratio
P0735 Gear 5 incorrect ratio
P0775 Pressure control solenoid "B" fault

Mr. Transmission told me that it skips 2nd gear and Slips in OD and pulled same codes. Said it would need internal inspection and $1395 + Hard Parts Costs. He thinks it could be a band or burn ring or something like that......kinda tuned out after he said they would need to get inside. What a sucker I think they thought.

After I left I tested the theory of skipping 2nd gear.....Well it could with normal to higher acceleration I think but with slightly less than normal accelerating it does shift into 2nd.

I am thinking like other posts I think if I replace the Solenoid block, filter and flush($300 I think) and see what happens......and maybe servo bore replacement per other threads.....Any websites and or links to where to buy quality parts as well!!

Please any help would be greatly appreciated!!!
 
<



imp

Explorer Addict
Joined
November 12, 2009
Messages
4,748
Reaction score
694
Location
West-Central AZ along the Colorado River
Year, Model & Trim Level
59 Ranchero F250 D'Line
OK I am thinking I may be posting what is already said, which I hope I missed it because that means someone has the same issue and cure/fix. I have an 03 XLT V8 with Tranny code V 5R55S I believe. Issue is hard shifting to second with normal acceleration and O/D light flashing. OK I noticed after warm up it shifts harder into 2nd gear and to make it shift smoother I have to accelerate easy but rest of gears shift normal. once engine/tranny warm up the OD light will come on and not shift into OD but will work if tranny isnt all the way warm or if I restart and od light goes out it wil shift in and out of OD as well with OD on/off switch.

Service engine light soon light on as well.....had it run at Autozone and had the following codes and was referred to Transmission shop for free diagnostic check.

Codes:
P0732 Gear 2 incorrect ratio
P0735 Gear 5 incorrect ratio
P0775 Pressure control solenoid "B" fault

Mr. Transmission told me that it skips 2nd gear and Slips in OD and pulled same codes. Said it would need internal inspection and $1395 + Hard Parts Costs. He thinks it could be a band or burn ring or something like that......kinda tuned out after he said they would need to get inside. What a sucker I think they thought.

After I left I tested the theory of skipping 2nd gear.....Well it could with normal to higher acceleration I think but with slightly less than normal accelerating it does shift into 2nd.

I am thinking like other posts I think if I replace the Solenoid block, filter and flush($300 I think) and see what happens......and maybe servo bore replacement per other threads.....Any websites and or links to where to buy quality parts as well!!

Please any help would be greatly appreciated!!!

Bought brand new Bosch solenoid module for my 5R55S year and a half ago, $185 on Ebay. If you go ahead, solenoid failure often generates a little pile of bronze chips ON TOP of the valve body; remove it, and clean careefully. Put an in-line filter in the line from the fluid cooler, to prevent debris getting back into new fluid. imp
 
<



bcbow1971

Member
Joined
June 4, 2012
Messages
25
Reaction score
0
City, State
Central KY
Year, Model & Trim Level
2003 Ford Explorer XLT4.6
Bought brand new Bosch solenoid module for my 5R55S year and a half ago, $185 on Ebay. If you go ahead, solenoid failure often generates a little pile of bronze chips ON TOP of the valve body; remove it, and clean careefully. Put an in-line filter in the line from the fluid cooler, to prevent debris getting back into new fluid. imp

Did you have same type of shifting issues? Forgot to mention it had 130,000 miles and new to me about six months and I am guessing never had an transmission filter and oil change either.
 
<



bcbow1971

Member
Joined
June 4, 2012
Messages
25
Reaction score
0
City, State
Central KY
Year, Model & Trim Level
2003 Ford Explorer XLT4.6
Got referral for a local shop that is honest from a few co-workers. They said the place I took it to first is high and not to go there. This guy said he will diagnose it by testing codes, pressure testing and dropping pan to inspect for $50. I am hoping it is not internal that I can't do!!!
 
<



Top