04 Explorer 4.0L 4x4 - cruise inop, brake lights stay on | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

04 Explorer 4.0L 4x4 - cruise inop, brake lights stay on

Deodand

New Member
Joined
May 24, 2018
Messages
2
Reaction score
0
City, State
Atlanta GA
Year, Model & Trim Level
2004 Explorer 4.0L 4x4
I'm working on a 2004 Explorer 4.0L 4x4. The cruise stopped working while I was pulling a box trailer. Now, when I depress the parking brake, the brake lights come on and stay on until the parking brake lever/pedal is released.

I have replaced the switch on the master cylinder (3L3Z-9F924-AB), the cruise switch SW6003 on the steering wheel, and the brake switch on the brake pedal (F4862) to no avail.

Also note that several different parts houses quoted me a brake switch SW6282 instead of the F4682, but the wiring harness plugs are different. We tracked down F4682 by trial and error. I even opened my original switch, cleaned the contacts and tested the spring, and put it back in, but also to no effect.

Does anyone know what is going on here?

It's possible that the two items are unrelated. My yard is flat, so I don't use the parking brake often, so I can not confirm that the two issues started at the same time.
 
<



Deodand

New Member
Joined
May 24, 2018
Messages
2
Reaction score
0
City, State
Atlanta GA
Year, Model & Trim Level
2004 Explorer 4.0L 4x4
Additional information, if it helps: I have verified that all tail, turn, brake, and headlights work fine when the parking brake lever is released/not engaged.
 
<



Top