04 explorer power window problem | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

04 explorer power window problem

cowboyboats

New Member
Joined
September 7, 2011
Messages
1
Reaction score
0
I'm having trouble getting all the power windows to work. Only the driver side window switches are illuminated(all of them). However on the driver side window operates, no other window works. Also no other window switch works either.
I'm getting 12v to the light blue/black wire to the driver side master switch. I have checked the #6 fuse and #62 under the hood and both are fine. I also checked the #17 fuse in the front driver compartment and it is fine as well. I have read about the "acc delay" relay but I'm not sure where it is. Any help would be appreciated.
 
<



BigRondo

USMC 1371
Staff member
Moderator
Elite Explorer
Joined
February 15, 2010
Messages
7,847
Reaction score
15
City, State
Charlestown, RI
Year, Model & Trim Level
2014 Escape SE
I'm having trouble getting all the power windows to work. Only the driver side window switches are illuminated(all of them). However on the driver side window operates, no other window works. Also no other window switch works either.
I'm getting 12v to the light blue/black wire to the driver side master switch. I have checked the #6 fuse and #62 under the hood and both are fine. I also checked the #17 fuse in the front driver compartment and it is fine as well. I have read about the "acc delay" relay but I'm not sure where it is. Any help would be appreciated.

Welcome aboard!! :salute:

The location of the delayed acc relay is in the owners manual. If you don't have an owner's manual, Dead Link Removed.

Sounds like it could be the master switch on the driver's door, but don't rule out faulty wiring!

I had similar electrical issues with my 02 xlt. The dome lights would stay on until the battery saver feature turned them off, the accessory delay wasn't working, the driver side puddle light didn't work, the keypad on the door would set off the alarm when I pressed it, the door ajar light would flash and beep at highway speeds, the radio would shut off as soon as I turned the key off, the delayed accessories didn't work, etc. Most recently all 4 windows stopped working.

A lot of electrical issues can be traced back to broken/damaged wire(s) in the boot between the body and the driver's door. I found 2 broken wires and repaired them. The thin black ground wire was broken and after repairing it all was back to normal. When the windows stopped working, I repaired the thick black ground wire and the windows now work like a champ.

Here is the thread for removing the door panel: http://www.explorerforum.com/forums//showthread.php?t=303524

Here is a great thread for checking for broken/damaged wires, thanks to synyster for this awesome write-up: http://www.explorerforum.com/forums//showthread.php?t=270081

Be sure to take your time when looking for broken/damaged wire(s). Check all the wires for breaks/damage. When you think you're done looking, look again, and again, and again. A bright flashlight can be very helpful.

If you find no broken/damaged wire(s) then check out this great link for troubleshooting the power windows, thanks to theofam for this great link Dead Link Removed

Let me know if you need and wiring diagrams for the windows. I have them for the '02, but they may help you out.


Hope this helps out! :D:thumbsup:

Please keep us posted as feedback helps others reading this post looking for a fix to the same or similar issue!
 
<



Top