• Register Today It's free! This box and some ads will disappear once registered!

13 ford exploer se lost nav when updated to 3.10.16


Daniel Burroughs

New Member
Joined
May 11, 2019
Messages
1
Reaction score
0
City, State
VIDOR
Year, Model & Trim Level
13 ford explorer se
Yes I made sure it was update with nav.checked forscan has number four where it's soppused to be.all systems in forscan shows nav is enabled.have nav on my mini screen on dash but have information on radio.have a6 map card.check card it does have software on there..can anyone help?
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.




pinkchihuahua

New Member
Joined
May 29, 2019
Messages
2
Reaction score
1
Year, Model & Trim Level
2011 Ford Edge SEL
Same thing happened to me yesterday. I called Ford support & they told me to bring my car to the dealer.
 




Adrian Gitch

Elite Explorer
Joined
February 15, 2019
Messages
288
Reaction score
35
City, State
Paris, KY
Year, Model & Trim Level
2015 Explorer Limited
Does your map card need to be more up to date? Like A9?
 




peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
28,351
Reaction score
1,729
City, State
Russell, Ontario (Ottawa area)
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
Welcome to the Forum Daniel.:wave:
Did you make any other changes with FORScan? A member lost al the Travel Link buttons after updating because he made a change to allow inputting while driving. Once he set it back to North America, his buttons came back.

Peter
 




pinkchihuahua

New Member
Joined
May 29, 2019
Messages
2
Reaction score
1
Year, Model & Trim Level
2011 Ford Edge SEL
I have the A10 maps. Got my Navigation back by downloading the Nav only file I found searching around on the internet. Everything works now.
 




Top