1993 Explorer Stalls | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

1993 Explorer Stalls

Gtrav

New Member
Joined
August 9, 2020
Messages
1
Reaction score
0
City, State
AB
Year, Model & Trim Level
1993 Explorer Eddie Bauer
My 1993 Explorer sat in my garage for about 1 yr. when I took it out, I changed the battery so I know that’s not the issue. Problem is that when I start the engine it will run for about 15 minutes and then stall. I have to wait about 30min and then it will start again. It will run again for about 10-15 and will stall again. I have changed out the gas, changed the fuel pump relay, changed the battery, oils good, no leaks from the engine. What’s the problem? Can anyone help me?
 
<



Centaurious

Well-Known Member
Joined
April 28, 2015
Messages
433
Reaction score
125
City, State
Pensacola FL
Year, Model & Trim Level
1994 Explorer Sport
Replace the fuel filter, it is probably full of water. Ethanol in the gasoline absorbs water until it reaches saturation. The paper filter media inside the fuel filter swells in contact with water. Thus your fuel filter is not passing hardly anything at this point.

I would pull the filter. Flush out all the dirt and sand from the disconnects before trying to remove. The auto parts stores sell replacement fingers for the disconnects if yours get damaged. Jumper the fuel pump relay to run the pump and pump out all the fuel. Let the fuel stand for several hours to let any water settle and refill the tank. If the flow of fuel is slow or slows down you may need to drop the tank, replace the filter sock on the pump, and hand clean the inside of the tank. If all is OK then install the new filter and check for problems.

Good Luck
 
<



Top