1993 Explorer that stalls. | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

1993 Explorer that stalls.

DirtyEx

New Member
Joined
March 9, 2010
Messages
1
Reaction score
0
City, State
Houston, Tx
Year, Model & Trim Level
1993 XLT 4x4
I have a '93 Ex xlt, 4x4 manual that has a sporatic stalling problem. When sitting at idle at a long light the idle gets very rough and starts to break up and bogs down. Most of the time i can restart the motor and pump the gas and it will clear. The problem had gone away for a while when I replaced the o2 sensor on the driver's side, before the cat. The truck ran good and I thought the problem was eliminated until today when it happened again.

Has this happened to anyone else? Or does anyone have any insight to what it might be??

Thanks,
Matt
 
<

Join the Elite Explorers $20 Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




BrooklynBay

Moderator & long time member.
Staff member
Moderator
Elite Explorer
Joined
November 11, 2005
Messages
55,304
Reaction score
736
City, State
Brooklyn, NY
Year, Model & Trim Level
88 89 93 95 96 Aerostars
<



MrShorty

Explorer Addict
Joined
December 27, 2001
Messages
5,078
Reaction score
17
City, State
Spanish Fork, UT
Year, Model & Trim Level
92 XLT and '87 Bronco II
I would start with some basic diagnostics: check for vacuum leaks, pull codes (even if CEL isn't on), and check fuel pressure. If there are any "tune-up" items that are due (spark plugs, wires, fuel filter, etc.) I'd probably get those done.
 
<



eric27

Member
Joined
August 25, 2010
Messages
34
Reaction score
0
City, State
northwest ohio
Year, Model & Trim Level
93 4.0 xlt
i had same problems. check pressure. idle should be around 30. try just the key on pressure. if below 20, you could have a faulty hose connecting your pump and metal fuel intake lines. also may be fuel filter.
 
<



tribestros

Member
Joined
May 3, 2009
Messages
23
Reaction score
0
City, State
League City, TX
Year, Model & Trim Level
'93 XLT
Mine does this exact thing. Hasn't gotten so bad to stall, I just pop it in park and give it a bit of gas.
 
<



Top