1993 stalling again ???? | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

  • Holiday Special! - 2 for 1 Elite Explorer sale!

    Right now you can purchase an Elite Explorer membership for $20 and receive a two year membership! If you have an existing Elite membership contact me by PM and I will upgrade your account manually.

    Click Here to start your membership and get rid of the ads!

1993 stalling again ????

mjatondo

Member
Joined
November 4, 2009
Messages
20
Reaction score
0
City, State
tulare ca
Year, Model & Trim Level
1993 xlt 4x4
i spoke too soon read below for the story ...my 93 explorer stalled again ...



about a moth ago my 1993 ford explorer xlt .4.0 6 cyl suv started making a a popping sound under the hood .like a muffled backfire.i put in a bottle of lucas problem was gone .a week later same thing again with idle low.so i changed spark plugs and fuel filter .problem stopped .for a few days.began to get progressively worse .no check engine light .began fuel odor and very bad gas mileage .i replaced the iac valve (new) started running perfect for about 10 minutes.all in all ive tested maf sensor ,tps, and looked for leaks.i haven't ran it on the computer tester because no check engine light.one thing i can add my temp on dash doesn't seem to be working right never goes above the first line .also my heater barely gives off heat.at present the car stars but wont run unless i pres down on the gas.and stalls most of the time i let it off ...someone help please
then....

Smile Second update
Purring like a kitten ... No black smoke ...so sputter... No stall..


For now .

Test drove it around town let it idle etc.rpm stable ..


So looks like for me ...

Replaced fuel filter

spark plugs

added lucas fuel injector cleaner

cleaned mass air flow sensor with (maf)approved cleaner

cleaned idle air control - replaced (didn't work)

bought a voltmeter tested all sensors ohms and voltage.

Purchased (iac) new ...two year warranty ... At auto zone 65.00

reset computer and bingo problem fixed
 




Top