1994 Idle Issue | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

1994 Idle Issue

mgmgmg

Elite Explorer
Joined
October 14, 2004
Messages
417
Reaction score
9
City, State
Plymouth, MN
Year, Model & Trim Level
'94 LTD '10 LTD V8
Ok heres the deal..... I have a rough idle cold and warm. did a code scan no codes pulled up did a turn up last yr plugs fuel filter etc.... look for vaccum leaks found none. when i start my explorer it whats to surge at a stop light...the tach stays at 750. When i put in in neutral it doesnt want to surge that bad. but when i put it in drive it starts to surge. When the exp warms up it seems to not surge any more or have a rough idle.
 
<

Join the Elite Explorers $20 Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




GuardianSport

Well-Known Member
Joined
May 20, 2009
Messages
377
Reaction score
1
City, State
Lindsay, ON
Year, Model & Trim Level
'04 ST Adrenalin
Clean the Idle Air Control, see how that works.
 
<



<



GuardianSport

Well-Known Member
Joined
May 20, 2009
Messages
377
Reaction score
1
City, State
Lindsay, ON
Year, Model & Trim Level
'04 ST Adrenalin
You can take them out and clean then with carb cleaner or electrical parts cleaner, my truck stalled frequently before I cleaned my IAC.
 
<



mgmgmg

Elite Explorer
Joined
October 14, 2004
Messages
417
Reaction score
9
City, State
Plymouth, MN
Year, Model & Trim Level
'94 LTD '10 LTD V8
Replaced the DPFE problem solved......
 
<



JAYBOOGY1717

Member
Joined
August 10, 2010
Messages
34
Reaction score
0
City, State
albany, ga
Year, Model & Trim Level
92 xplorer 2wd
fuel pressure regulator...sound like the symptoms mine had when it went out
 
<



MrShorty

Explorer Addict
Joined
December 27, 2001
Messages
5,078
Reaction score
17
City, State
Spanish Fork, UT
Year, Model & Trim Level
92 XLT and '87 Bronco II
Replaced the DPFE problem solved......
Because diagnosis is often most of the battle, would you care to describe how you determined the DPFE was at fault?
 
<



mgmgmg

Elite Explorer
Joined
October 14, 2004
Messages
417
Reaction score
9
City, State
Plymouth, MN
Year, Model & Trim Level
'94 LTD '10 LTD V8
I replaced my fuel pressure regulator few yrs back....pulled the vent cap off found no gas.....

Pull codes

c= 336
 
<



Top