2000 AWD Xploder from Turbo back to NA | Page 67 | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

  • Holiday Special! - 2 for 1 Elite Explorer sale!

    Right now you can purchase an Elite Explorer membership for $20 and receive a two year membership! If you have an existing Elite membership contact me by PM and I will upgrade your account manually.

    Click Here to start your membership and get rid of the ads!

2000 AWD Xploder from Turbo back to NA

After getting an estimate on how much it would run me to fix up my Xploder with all new exhaust, cold side piping, and a bunch of other stuff done up the "right" way... I've decided to convert my Xploder back to NA form so that I can actually ENJOY the truck before I die of old age.

Anyways... To start it off I ordered up a MAC cold air intake (I do not have the stock intake) and sold my FMS headers on ebay.

I plan on buying a set of torque monster headers in the next week or so but am still up in the air on how I should run my exhaust from a performance "speed" perspective. I do not plan on doing much, if any, off road driving, so am looking for a setup that improves take off and speed for spirited pavement driving that sounds good.

I already have the spare tire removed (and will be keeping it off, I have free towing anyways lol)... What would an optimal setup be with the above in mind and no worry of a spare tire being in the way? True duals (straight pipe off of each header, thru separate mufflers, and out the sides), or a dual exhaust both going into a 2 in 2 out "H" pipe style muffler and then out the sides? Or something else? In all cases I won't be running any cats.

I also plan to re-tune my car since currently it is tuned for the turbo setup which obviously will no longer apply once I rip everything out.

Thank you for any input! :)
 


Holiday Special! Join the Elite Explorers $20 for 2 years! Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




XploderPhil

Elite Explorer
Joined
January 5, 2021
Messages
81
Reaction score
33
City, State
Grants Pass, Oreygun
Year, Model & Trim Level
99 Explorer XLT 5.0 AWD
Your write up inspired me earlier this year to convert mine to led. I love it

20210209_163256.jpg 20210209_163449.jpg 20210212_113510.jpg 20210209_184233.jpg
 

Attachments

  • 20210209_163256.jpg
    20210209_163256.jpg
    203.6 KB · Views: 9
  • 20210209_163449.jpg
    20210209_163449.jpg
    296.9 KB · Views: 7
  • 20210212_113510.jpg
    20210212_113510.jpg
    270.6 KB · Views: 8


Holiday Special! Join the Elite Explorers $20 for 2 years! Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




willzilla

Elite Explorer
Joined
July 14, 2010
Messages
1,144
Reaction score
91
City, State
San Antonio, TX
Year, Model & Trim Level
2000 XLT AWD
Your write up inspired me earlier this year to convert mine to led. I love it
Awesome! Looks great! Did your flex cable or whatever that stuff is also break on your prior to the conversion?? :)
 




XploderPhil

Elite Explorer
Joined
January 5, 2021
Messages
81
Reaction score
33
City, State
Grants Pass, Oreygun
Year, Model & Trim Level
99 Explorer XLT 5.0 AWD
Awesome! Looks great! Did your flex cable or whatever that stuff is also break on your prior to the conversion?? :)
Yes, I could get it to work off and on, mostly off 🙄
 




willzilla

Elite Explorer
Joined
July 14, 2010
Messages
1,144
Reaction score
91
City, State
San Antonio, TX
Year, Model & Trim Level
2000 XLT AWD




willzilla

Elite Explorer
Joined
July 14, 2010
Messages
1,144
Reaction score
91
City, State
San Antonio, TX
Year, Model & Trim Level
2000 XLT AWD
Have been busy working on the ZL1 mostly past few weeks and trying to put together YouTube videos as I go, lol. Hope to MAYBE finally getting back to the Xploder. It's been driving well the few times I take it for a spin other than the belt squeal on startup that I need to resolve... again.

I've also been thinking of plasti-dipping the Xploder to help protect it as I have a few small suface rust spots, some clear coat peel on the fenders, etc... And maybe sanding the rust spots down a bit and tossing in some touch up paint, sanding the clear off the fenders, and then maybe hitting the car with something from Dip Club would be a fun project.

Before all of that I still need to get the AC up and running, lol, as well as drain the transmission and get that fresh fluid in there, and figure out the ABS light (wheel speed sensor probably I'm guessing at this point), and a million other things, haha :D

Meanwhile... a few fun ZL1 videos, lol:



Oooo.. And I emptied the catch can I installed in my ZL1 for the first time this past weekend (only about 600-800 miles of wimpy driving)... Caught a decent amount of oil and gunk:

20211119-182539.jpg

20211119-182549.jpg
 




Top