2001 Explorer Fuel Pump | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

2001 Explorer Fuel Pump

Westley

New Member
Joined
February 8, 2013
Messages
8
Reaction score
0
City, State
Raleigh, Nc
Year, Model & Trim Level
2001 Ford Explorer
Problem!

Fuel pump engages but no pressure at rail or filter. Yesterday, after much hassle, I did get 65 psi at the rail and the truck started periodically for the rest of the day. This morning same problem. Checked pressure at the rail and at the filter...nothing. And I haven't been able to get it started.

I can hear the fuel pump running the prime cycle when I turn the key on. The fuel pump was replaced approx 5 months ago. Issue started about a week ago and got progressively worse.

Could something be disconnected on the pump? Is there something I might try prior to dropping the tank? I have about 3/4 of a tank!
 
<



koda2000

Explorer Addict
Joined
September 2, 2011
Messages
13,850
Reaction score
1,495
Year, Model & Trim Level
x
on the 2001, the pressure regulator is part of the in-tank assembly, i guess it's possible it's not working properly. also, there is a small length if fuel line that connects the pump to the regulator. this piece of hose is held in place with two hose clamps. this hose can leak and lose fuel pressure. either way, you need to drop the tank and pull out the assembly to check/repair or replace it. if you'd like directions on how to do this, PM me.
 
<



Westley

New Member
Joined
February 8, 2013
Messages
8
Reaction score
0
City, State
Raleigh, Nc
Year, Model & Trim Level
2001 Ford Explorer
Thanks. I did the fuel pump last time. I was just wondering if something else could be the issue. Although, I don't believe the regulator is in the tank. Are you sure?
 
<



koda2000

Explorer Addict
Joined
September 2, 2011
Messages
13,850
Reaction score
1,495
Year, Model & Trim Level
x
Yes - I'm sure the regulator is in the tank on a 2001.
 
<



Top