2002 Eddie Bauer left rear turn signal/brake light failure | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

  • Holiday Special! - 2 for 1 Elite Explorer sale!

    Right now you can purchase an Elite Explorer membership for $20 and receive a two year membership! If you have an existing Elite membership contact me by PM and I will upgrade your account manually.

    Click Here to start your membership and get rid of the ads!

2002 Eddie Bauer left rear turn signal/brake light failure

finiteguy

Active Member
Joined
June 10, 2012
Messages
62
Reaction score
0
Year, Model & Trim Level
2002 Explorer Eddie Bauer
My left rear turn signal and brake light no longer work. I replaced the bulb and still doesn't work. Seems like it could be a broken wire. there is no voltage to the socket. Odd that it's one side only. Anyone know what could be wrong?
 




BigRondo

USMC 1371
Elite Explorer
Moderator Emeritus
Joined
February 15, 2010
Messages
7,858
Reaction score
14
City, State
Worcester, MA
Year, Model & Trim Level
2002 XLT V6 4x4
My left rear turn signal and brake light no longer work. I replaced the bulb and still doesn't work. Seems like it could be a broken wire. there is no voltage to the socket. Odd that it's one side only. Anyone know what could be wrong?

I should be able to send some good info tomorrow after work!
 




finiteguy

Active Member
Joined
June 10, 2012
Messages
62
Reaction score
0
Year, Model & Trim Level
2002 Explorer Eddie Bauer
I should be able to send some good info tomorrow after work!

Thanks. I've been reading up on this and it looks like people have found the problem to be in the steering column.
 




BigRondo

USMC 1371
Elite Explorer
Moderator Emeritus
Joined
February 15, 2010
Messages
7,858
Reaction score
14
City, State
Worcester, MA
Year, Model & Trim Level
2002 XLT V6 4x4
Thanks. I've been reading up on this and it looks like people have found the problem to be in the steering column.

Sorry about the delay. Check your PM. I have sent some good info. ;):thumbsup:

Let me know if there is anything else you need. :thumbsup:

Please keep us posted as feedback helps others reading this post looking for a fix to the same or similar issue!
 




Top