2002 Ford Explorer XLS Instrument Cluster | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

2002 Ford Explorer XLS Instrument Cluster

lmarkie74

Active Member
Joined
April 30, 2017
Messages
70
Reaction score
2
City, State
Morganton
Year, Model & Trim Level
2013, Ford Explorer, XLS
Having a problem with my Instrument Cluster, 1L2F-10849-AH. All these LED lights do not light up: Check Engine, O/D OFF, Park Brake, Door Ajar, Fuel Cap, Air Bag, ABS, 4x4, 4x4 Low. Pretty much not many of them do come on.

There is a self-diagnostic test that will let you check everything. Press Reset and hold. Turn key to Run (Not Start). Wait about 3 seconds and the LED will read Test. Toggle through the tests until you come to "bulb". This will tell you which ones are working.

Here is my question. I came across a procedure for a swap. When you find a cluster with the same part# and change you're LED display to the new one, it should work with the correct mileage. Anyone done this before?

I called a local guy that does cluster repairs. He says you have to have the mileage and the VIN reprogrammed into the new cluster or it will not work. Is this true?
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





@Mark Lammers "He says you have to have the mileage and the VIN reprogrammed into the new cluster or it will not work. Is this true?"

True, that. VIN into ABS replacement, too. imp
 






funny, i swapped the cluster in my 02 mounty, and my mileage stayed correctly. But it didnt fix my "no lights" issue.
 


















Back
Top