2003 Explorer blend door actuator. | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

2003 Explorer blend door actuator.

p.swiderski

New Member
Joined
October 1, 2010
Messages
2
Reaction score
0
City, State
Rogers, MN
Year, Model & Trim Level
2003 XLT
Jumped into my Explorer yesterday and didn't have any heat. AC works great but when I put the dial to heat it blows cold air. I don't have any clicking noises so I'm not sure if it's the Actuator or not. Any ideas? I've done some more diagnosis and the heater line going into the fire wall is hot but the one coming out is cold. I'm leaning toward the blend door actuator but I'm still not positive that is the problem.
 
<

Join the Elite Explorers $20 Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




BrooklynBay

Moderator & long time member.
Staff member
Moderator
Elite Explorer
Joined
November 11, 2005
Messages
55,303
Reaction score
736
City, State
Brooklyn, NY
Year, Model & Trim Level
88 89 93 95 96 Aerostars
<



Donsnoozer

New Member
Joined
December 15, 2009
Messages
3
Reaction score
0
City, State
quakertown, pa
Year, Model & Trim Level
1997XLT
I have the same problem,A/C not real cold no heat the blend door seems like its closed all the time.Does not seem to be any variation in the temp.ANY IDEAS OUT THERE. Donsnoozer
 
<



p.swiderski

New Member
Joined
October 1, 2010
Messages
2
Reaction score
0
City, State
Rogers, MN
Year, Model & Trim Level
2003 XLT
I solved my heater problem. It was the vacume valve from the heater hose to the heater core. It looked like it was still working and moving when the A/C was on and off but is was stuck shut so no water was going to the core.
 
<



BrooklynBay

Moderator & long time member.
Staff member
Moderator
Elite Explorer
Joined
November 11, 2005
Messages
55,303
Reaction score
736
City, State
Brooklyn, NY
Year, Model & Trim Level
88 89 93 95 96 Aerostars
<



thebraves

New Member
Joined
December 2, 2011
Messages
3
Reaction score
0
City, State
Virginia
Year, Model & Trim Level
2003 Ford Explorer
I have a 2003 Explorer and I have an issue where the door that is right behind the two main vents (below the radio) does not close when the defroster is selected. This keeps all the hot air from being directed to the defroster. I see lots of talk about fixing the blend door but I don't think that is what this door is called. Also, I don't know if the actuator for this door is on the left or right. I hope someone can help me. I need to know the door name so I can see if I can find help to fix it.

Thanks!!
 
<



pimph80

New Member
Joined
October 25, 2011
Messages
3
Reaction score
0
Year, Model & Trim Level
1999 Explorer
Heater not working

I have a 99 Ford Explorer and the heater is not working. The AC works just fine. I was told that the vent is probably not opening and to look under the dash behind the radio. I also heard it could be the vacuum hose. Any ideas?
 
<



FordDerk

New Member
Joined
December 5, 2011
Messages
1
Reaction score
0
City, State
Sacto
Year, Model & Trim Level
2004, XLT Explorer
Dear thebraves, Look at this post. My 04 exp did same thing.

http://www.explorerforum.com/forums/showthread.php?t=249624

I fixed mine by drilling a hole in the black plastic part that the silver arm attaches to. After drilling the hole, I just connected to silver arm to the plastic part with a zip tie. Works fine now. Access, repair work and viewing can be done by opening the glove box all the way. Shine a light up towards the top center of the dash. It should look like the photos in the link I provided.
 
<



Top