• Register Today It's free! This box and some ads will disappear once registered!

2003 Ford Explore fuel pump not engaged

Dredus

Member
Joined
August 30, 2020
Messages
12
Reaction score
0
City, State
St. Louis, Missouri
Year, Model & Trim Level
2003 Ford Explore
Have replaced almost everything I can think of and will not start
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.




MakinJeepsWeep!

Elite Explorer
Joined
October 1, 2020
Messages
311
Reaction score
89
City, State
Polk County Texas
Year, Model & Trim Level
96 Explorer 5.0L AWD
Callsign
Big Red
Can we get some more information? What motor, wont crank, cant hear fuel pump run ect ect?
 




hondaslave1342

Well-Known Member
Joined
July 7, 2017
Messages
135
Reaction score
9
City, State
Chattanooga
Year, Model & Trim Level
2005 Ford Sport Trac XLT
Have replaced almost everything I can think of and will not start
Did you check the enertia switch under passenger glove box? If it's tripped the fuel pump will turn on
 




Dredus

Member
Joined
August 30, 2020
Messages
12
Reaction score
0
City, State
St. Louis, Missouri
Year, Model & Trim Level
2003 Ford Explore
Did you check the enertia switch under passenger glove box? If it's tripped the fuel pump will turn on
Have replaced twice thinking the first was damaged when bought
 




MakinJeepsWeep!

Elite Explorer
Joined
October 1, 2020
Messages
311
Reaction score
89
City, State
Polk County Texas
Year, Model & Trim Level
96 Explorer 5.0L AWD
Callsign
Big Red
What about fuel pump relay under hood? Can swap with ac relay for testing.
 




Dredus

Member
Joined
August 30, 2020
Messages
12
Reaction score
0
City, State
St. Louis, Missouri
Year, Model & Trim Level
2003 Ford Explore
Can we get some more information? What motor, wont crank, cant hear fuel pump run ect ect?
Can not Hear fuel pump have replaced pump twice. Spark plugs changed. Battery cables Throttlebody and more
 








MakinJeepsWeep!

Elite Explorer
Joined
October 1, 2020
Messages
311
Reaction score
89
City, State
Polk County Texas
Year, Model & Trim Level
96 Explorer 5.0L AWD
Callsign
Big Red
So the problem is indeed your fuel pump is not kicking on correct? Everything else works as it should? All the dings and lights come on it rolls over when cranking? Does it even try to spit at you or does nothing but roll over?
 




Dredus

Member
Joined
August 30, 2020
Messages
12
Reaction score
0
City, State
St. Louis, Missouri
Year, Model & Trim Level
2003 Ford Explore
So the problem is indeed your fuel pump is not kicking on correct? Everything else works as it should? All the dings and lights come on it rolls over when cranking? Does it even try to spit at you or does nothing but roll over?
Yes en
So the problem is indeed your fuel pump is not kicking on correct? Everything else works as it should? All the dings and lights come on it rolls over when cranking? Does it even try to spit at you or does nothing but roll over?
Yes the
So the problem is indeed your fuel pump is not kicking on correct? Everything else works as it should? All the dings and lights come on it rolls over when cranking? Does it even try to spit at you or does nothing but roll o
So the problem is indeed your fuel pump is not kicking on correct? Everything else works as it should? All the dings and lights come on it rolls over when cranking? Does it even try to spit at you or does nothing but roll over?
So the problem is indeed your fuel pump is not kicking on correct? Everything
So the problem is indeed your fuel pump is not kicking on correct? Everything else works as it should? All the dings and lights come on it rolls over when cranking? Does it even try to spit at you or does nothing but roll over?
yes it turns but you don’t hear the two second hum for the fuel pump
 




MakinJeepsWeep!

Elite Explorer
Joined
October 1, 2020
Messages
311
Reaction score
89
City, State
Polk County Texas
Year, Model & Trim Level
96 Explorer 5.0L AWD
Callsign
Big Red
Well if you have already done the relays and the switch, the only things left is wiring and the pump itself. Bout the only things left to check. You could hook power to the pump direct to test it.
 




Dredus

Member
Joined
August 30, 2020
Messages
12
Reaction score
0
City, State
St. Louis, Missouri
Year, Model & Trim Level
2003 Ford Explore
Well if you have already done the relays and the switch, the only things left is wiring and the pump itself. Bout the only things left to check. You could hook power to the pump direct to test it.
Well if you have already done the relays and the switch, the only things left is wiring and the pump itself. Bout the only things left to check. You could hook power to the pump direct to test it.
Have bought and wired two fuel pumps wiring is done but not engaging
 








Dredus

Member
Joined
August 30, 2020
Messages
12
Reaction score
0
City, State
St. Louis, Missouri
Year, Model & Trim Level
2003 Ford Explore
I'd start looking for a burnt connector
I’ve searched nothing looks burnt.
When it stopped over a year ago I was at a red light when I moved on green accelerator didn’t go fast and with in minutes lost power
 
















donalds

Elite Explorer
Joined
July 12, 2015
Messages
3,716
Reaction score
1,427
Location
Stem
City, State
Nc
Year, Model & Trim Level
1999 ford explorer sohc
Next to the gas tank in the frame rail
May be one there
 








donalds

Elite Explorer
Joined
July 12, 2015
Messages
3,716
Reaction score
1,427
Location
Stem
City, State
Nc
Year, Model & Trim Level
1999 ford explorer sohc
Are you referring

Are you referring to one on the fuel pump
No but follow that wire harness back should be one
Mine is in front of the gas tank
That connector runs everything on the back of the truck basically lights ect.
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.








Top