2003 Mountaineer - No power windows, gages, radio, chimes, etc. HELP!! | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

  • Holiday Special! - 2 for 1 Elite Explorer sale!

    Right now you can purchase an Elite Explorer membership for $20 and receive a two year membership! If you have an existing Elite membership contact me by PM and I will upgrade your account manually.

    Click Here to start your membership and get rid of the ads!

2003 Mountaineer - No power windows, gages, radio, chimes, etc. HELP!!

T-Bone75

New Member
Joined
March 25, 2015
Messages
3
Reaction score
0
City, State
Iowa
Year, Model & Trim Level
2003 Mercury Mountaineer
I have read numerous posts on these items not working. I would like to share everything I have checked and ask what I should do next.

1. I tore the door apart and check the wires coming through the boot from the door to the body. I found a larger black wire that had been repaired before (not soldered). Also two smaller broken wires that I traced to the Driver preset buttons. I fixed those properly by soldering and heat shrinking them. Did not fix the problems.

2. I checked continuity of that black wire I fixed and the light blue/black wire from the window switch to the fuse box. Checked ok. There was no voltage on the light blue/black wire with the key on.

3. Check numerous fuses and relays. #17 fuse, delayed accessory fuse (60A) and relay, Battery saver relay. All check good. I removed them, checked them and put them back in. Did not fix the problems.

4. I retrieved code B1342 GEM Defective a couple months ago, but it does not exist now. I haven't driven it much between that code and now.

5. A couple weeks ago the Liftgate Ajar was on constantly, the alarm would go off randomly and the dome light would stay on. I sprayed the latch with WD40 and it went away.

I have read some other troubleshooting webpages and have come to the conclusion the GEM (generic electronic module) or the ICM (Instrument Cluster Module) needs to be replaced. I have read mixed info on whether or not a 2003 is GEM controlled or ICM controlled.

I am at a standstill now and my next move is to start changing out parts (I hate doing that!!!). Does anyone out there see anything I may have missed? Does anyone out there have experience changing out the GEM or ICM? Where is the GEM located? Is the ICM simply the complete instrument cluster? Thanks in advance for your help.
 




Top