2004 explorer 4.0 stalling | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

2004 explorer 4.0 stalling

Post number 4 has been selected as best answered.

Chasantyl

New Member
Joined
August 2, 2013
Messages
2
Reaction score
0
Year, Model & Trim Level
2004 explorer 4.0
I have a 2004 4.0 that some days runs normal other days will stall and not re-crank for several minutes. I have replaced fuel pump,fuel filter,and the throttle body control motor. Still getting a p0191 and p0193 need help thanks
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





I have a 2004 4.0 that some days runs normal other days will stall and not re-crank for several minutes. I have replaced fuel pump,fuel filter,and the throttle body control motor. Still getting a p0191 and p0193 need help thanks

What do you mean by "recrank"? Do you mean it won't start?

P0191 and P0193 are both related to malfunction of the Fuel Rail Pressure Sensor. If that device "goes out", the fuel pump will NOT RUN, and the engine cannot start.

Clarify please what your symptom is, and we'll go farther into it. imp
 






What it does is it will crank but runs ruff and won't run right until you let it sit awhile
 






I would replace the Fuel Rail Pressure and Temperature Sensor. Costs a little over a hundred bucks. Get intake manifold gaskets just in case old ones aren;t reuseable. $20 more. imp
 






going bad tdc crank sensor.
 






Back
Top