2007 Loses power after 30 minutes | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

  • Holiday Special! - 2 for 1 Elite Explorer sale!

    Right now you can purchase an Elite Explorer membership for $20 and receive a two year membership! If you have an existing Elite membership contact me by PM and I will upgrade your account manually.

    Click Here to start your membership and get rid of the ads!

2007 Loses power after 30 minutes

pdkersch

New Member
Joined
December 29, 2015
Messages
1
Reaction score
0
City, State
Asheville, NC
Year, Model & Trim Level
2007 Explorer
After 30 minutes of driving mainly uphill (NC Mountains Blue Ridge Parkway). it looses power and the RPM start to increase. If I was going 45 it dropped to about 25. I've had it checked but they could find no issues or codes. I'm sure they didn't drive it 30 min uphill either. One friend suggested Vapor Lock and to wrap the fuel line in a reflective insulation tape. This started a month ago but the vehicle was totally fine after spending a month in the Colorado mountains. It has 100,000K on it. Suggestions?
 




suzook

Well-Known Member
Joined
December 31, 2006
Messages
327
Reaction score
22
City, State
ny
Year, Model & Trim Level
2018 Explorer XLT
Rpm rises, speed decreases??? Sounds like a transmission.
 




Flag Gibby

Explorer Addict
Joined
October 14, 2012
Messages
1,641
Reaction score
3
City, State
Flagstaff, AZ
Year, Model & Trim Level
2006 Mountaineer AWD
Anything else like the vehicle temperature gauge indicating hotter than normal? V8 or V6 motor? Transmission searching for the right gear to be in? Engine idling high when the loss of power happens?
 




Top