• Register Today It's free! This box and some ads will disappear once registered!

2007 Ranger Climate Control

toby7777

New Member
Joined
September 26, 2009
Messages
1
Reaction score
0
Year, Model & Trim Level
2007 Ranger
Hi, I'm new to the forum. I have an 07 Ranger (39k miles). The climate control system seems to be acting weird. Here are the problems:
The center knob that controls temperature seems to have no effect. The temperature is cold.
The right knob that controls flow kicks the ac compressor on when directing flow to defrost, floor/defrost, floor/vents, and both AC and Max AC settings.
When the right knob is set to just vents, or floor the ac compressor does not turn on.
All of the vaccuum pods seem to be working just fine and directing air ok.

Is there a module or ecu for the climate control that maybe fried??

Thanks for any help.
Toby
 




TheJackal

Explorer Addict
Joined
August 11, 2007
Messages
1,060
Reaction score
3
City, State
Mandeville, LA
Year, Model & Trim Level
1999 Explorer XL 2WD
I don't know much about newer models but the 2nd Gen Explorers, the A/C compressor operates in all modes except VENT or OFF.

If you're looking for heat but not getting any, it could be a problem with the blend door or actuator (a common issue in the 2nd Gens), the heater core bypass valve, or the cooling system. The 2nd Gens have a vacuum-operated heater core bypass.
 




bisjoe

Well-Known Member
Joined
March 7, 2006
Messages
463
Reaction score
1
City, State
Sammamish, WA
I have an '07 Ranger too, and the A/C (& dehumidify) compressor runs on all but the vent (upper left between A/C and off) and the floor only setting. Has since new.

The temperature knob not working is probably going to require the dash coming off, too bad the warranty is up. I have a few thousand miles to go.
 




Top