• Register Today It's free! This box and some ads will disappear once registered!

2008 Explorer AC problem


Hanukkah

New Member
Joined
May 13, 2013
Messages
2
Reaction score
0
Year, Model & Trim Level
2008 Explorer EB200
Bought this explorer used and not running condition...

No communication vai OBD... so I replaced PCM. Got a PCM from a Mercury Mountaineer and programmed PATS keys..

Car starting but AC does not turn on. There is plenty of freon in the system.

Does the PCM also control the HVAC system? I have not reflashed this PCM yet.

Still waiting for my J5234 dongle.... while waiting I wanted to check and see if this HVAC issue is or is not PCM related.

Hope for your inputs.

Thanks
 




Hanukkah

New Member
Joined
May 13, 2013
Messages
2
Reaction score
0
Year, Model & Trim Level
2008 Explorer EB200
Just an update...

From this link: http://www.explorerforum.com/forums/showthread.php?t=156976

I tested the low pressure switch. Switch removed from system, no continuity. Switch plugged into system - shorted. Shorting the wires of this socket does not engage the AC clutch.

I can manually activate the AC clutch... Checked the AC diode and relays all working.

Traced the line from AC relay to the PCM.

So have to wait for the J2534 pass thru and reprogram PCM to confirm if these are calibration issues or I have got a faulty used PCM...:scratch:

Maybe the root of the problem was PCM part numbers. Original is 8L2A-12A650-GB. The used PCM I got was 8L2A-12A650-HE.

I thought the last 2 calibration codes (XX) were not that important... 82LA-12A650-XX. Looks to me that they are. Hehe.
 




Top